pivot-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Bartlett <cbartlet...@gmail.com>
Subject Re: Pivot unit testing
Date Wed, 29 Jun 2011 18:13:18 GMT
Sandro has suggested moving to JUnit 4.8.2 for the 2.1 release which sounds
fine to me.
4.8.2 is already well over a year old according to the timestamp here
https://github.com/KentBeck/junit/downloads
junit-4.8.2.jar   231KB   Uploaded April 09, 2010
As it is only involved with the testing and not required at runtime, I don't
see a problem with agreeing on a relatively new version.  After all, Pivot
itself requires an up to date JRE and it shouldn't impact too many people
anyway.

Anyone else have any thoughts or can we agree to switch to JUnit 4.8.2 once
Pivot 2.0.1 is released?

Chris

On 29 June 2011 18:43, Greg Brown <gk_brown@verizon.net> wrote:

> > 1) Is there an 'official' minimum version of JUnit expected for Pivot's
> > build?
>
> I believe it is 4.7.
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message