pivot-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Roger Whitcomb <Roger.Whitc...@actian.com>
Subject RE: Applet-related question
Date Tue, 21 Apr 2015 21:35:35 GMT
Okay, I figured out where the reference to the versioned file name is coming from:  the "indexJars"
value on the "jar" task:
From build.xml:
            <jar destfile="${folder.lib}/@{jarFile}" index="${compiler.indexJars}">

From build.properties:
compiler.indexJars=true

The contents of the META-INF\INDEX.LIST:
JarIndex-Version: 1.0

pivot-wtk-terra-2.1.0.jar
org
org/apache
org/apache/pivot
org/apache/pivot/wtk
org/apache/pivot/wtk/skin
org/apache/pivot/wtk/skin/terra
org/apache/pivot/wtk/skin/terra/doc-files

So, the solution to this problem is to disable the "indexJars" property in the "build.properties"
for my Pivot builds and instead index the .jars from my application (which will have the non-versioned
file names).

Thanks,
~Roger

-----Original Message-----
From: Roger Whitcomb [mailto:Roger.Whitcomb@actian.com] 
Sent: Monday, April 13, 2015 11:35 AM
To: dev@pivot.apache.org
Subject: RE: Applet-related question

I did try cleaning up the Java cache, but I didn't clear it completely, so I will try that.
 Also will try a different browser (I was using Firefox 36.0.4).  Our applet is not using
any native code libraries (those are all on the server side, and never reference Pivot code).

Let me see if I can test using a small applet.  I do have one I can modify easily.  If so
I will post along with a new JIRA issue.  I don't have any publicly-available VMs to test
with, sorry ....

Ciao,
~Roger

-----Original Message-----
From: Sandro Martini [mailto:sandro.martini@gmail.com] 
Sent: Monday, April 13, 2015 9:30 AM
To: dev@pivot.apache.org
Subject: Re: Applet-related question

Ciao Roger,
after some checks on code base I didn't find anything with hard-coded dependency to wtk-terra
(I was almost sure there wasn't) ... so sorry some (obvious) questions:
- you already tried to clean up Java cache (In the Contol panel), right ?
- did you tried even with different Browsers ?
- last, are you sure there isn't some hard-coded dependency even in native code libraries
used in your app ?

If all this is Ok maybe we could really have some problem related to Classloaders ...


In our tests we have a sample html page to test an Applet, it was used to test/fix issue 859,
it's pivot859.html ... could you try with a minimized version if possible (as dependencies)
of your application ?

Anyway, if you could isolate the problem in a test applet/application it would help a lot
to better understand where the problem is ... or have you got a vm somewhere so I can try
to connect ?

Tell me for updates.

Bye

Mime
View raw message