plc4x-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Julian Feinauer <j.feina...@pragmaticminds.de>
Subject Re: S7 DATA_BLOCKS error
Date Fri, 29 May 2020 08:38:52 GMT
Hi,

sorry for being late (ist still morning, right).
But @Joris Suppers<mailto:j.suppers@sotec.eu> you are missing the DB Number.
And I think we handle that pretty poorly with our exception.

It should be builder.addItem("value-4", "%DB{DB-Number}.DB1.4:INT");

Cheers!
Julian


Von: Joris Suppers <j.suppers@sotec.eu>
Antworten an: "dev@plc4x.apache.org" <dev@plc4x.apache.org>
Datum: Freitag, 29. Mai 2020 um 10:11
An: "dev@plc4x.apache.org" <dev@plc4x.apache.org>
Cc: CloudPlug Development <cloudplug-dev@sotec.eu>
Betreff: S7 DATA_BLOCKS error

Hey Everyone,

We are currently testing the Siemens S7 connector (S7_1200) using the scrapper, and have come
into an issue.

When testing the values as shown in the "Getting Started" page (https://plc4x.apache.org/users/plc4j/gettingstarted.html)
we can successfully read the following values:
builder.addItem("value-1", "%Q0.4:BOOL");
builder.addItem("value-2", "%Q0:BYTE");
builder.addItem("value-3", "%I0.2:BOOL");

However when testing:
builder.addItem("value-4", "%DB.DB1.4:INT");
There is a Connection-Alias error:[cid:ii_karwzil70]

I have also tried the other syntax shown in "https://plc4x.apache.org/users/protocols/s7.html"
 However, no luck.

We are using a 0.7.0-SNAPSHOT version, I have also tested with 0.7.0.

Is there something that still needs to be done? Any suggestions or comments would be appreciated.

Many thanks,
Joris




--
Joris Suppers | SOTEC | j.suppers@sotec.eu<mailto:j.suppers@sotec.eu> | T +49 7033 5458
72


www.sotec.eu<http://www.sotec.eu/>

SOTEC Software Entwicklungs GmbH + Co Mikrocomputertechnik KG

Calwer Straße 11, D-75395 Ostelsheim

Sitz Ostelsheim, Amtsgericht Stuttgart HRA 330821/HRB 330664, Geschäftsführer: Florian Holz
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message