plc4x-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christofer Dutz <christofer.d...@c-ware.de>
Subject Re: [DISCUSS] Apache PLC4X 0.7.0 RC1
Date Tue, 19 May 2020 15:42:54 GMT
Hi all,

I think I'll cancel this RC and cut a new one. Otto is actually right ... it should work with
Java 8 and it doesn't.
Also who am I to encourage people with non-binding votes telling them that their votes count
and then not to respect them (Ok ... technically we'd still have enough)

So I'll whip up a new RC asap ... one with the fix.

Chris



Am 19.05.20, 14:34 schrieb "Otto Fowler" <ottobackwards@gmail.com>:

     I think you should cut another RC with the fix in it.  With an Apache
    project the code _IS_ the product as well.  And this product (RC1) does not
    work as documented.

    RC’s are cheap, and we have scripts to help.  What is the project based
    reason to rush this?



    On May 19, 2020 at 04:30:58, Christofer Dutz (christofer.dutz@c-ware.de)
    wrote:

    Hi,

    And to be on the safe-side, I would mention it in the Announce email ...
    and on the download page.

    I'll leave this discussion and the vote open till this afternoon so
    everyone has the chance to express his/her feelings about this.

    Chris

    Am 19.05.20, 09:42 schrieb "Robinet, Etienne" <43823@etu.he2b.be>:

    Hi,
    I also agree with Chris

    Etienne

    Le mar. 19 mai 2020 à 08:40, Julian Feinauer <j.feinauer@pragmaticminds.de>
    a écrit :

    > Hi,
    >
    > I would ship the RC as I fully agree with your argumentation.
    > My opinion.
    >
    > Julian
    >
    > Am 19.05.20, 08:20 schrieb "Christofer Dutz" <christofer.dutz@c-ware.de>:
    >
    > Hi all,
    >
    > so I tracked down the problem Otto found.
    >
    > It seems that the setting we are using in surefire and failsafe to
    > allow illegal access, is unknown to Java 8.
    > The strange thing is that we have this setting in all modules and only
    > in the mspec module it seems to be causing problems.
    > I moved the setting into a self-activating profile that enables itself
    > for java 9 and higher. Now I can build with Java 8.
    >
    > So in the future this problem is solved.
    >
    > So now the question ... should we cancel the RC or continue?
    >
    > As this issue has absolutely no effect on the end-product and only
    > occurs at build time if using Java 8, I would feel comfortable with
    > treating it as a documentation issue and just release the next version
    > 0.8.0 a lot sooner than 0.7.0.
    >
    > But I'll leave that up to you.
    >
    > Chris
    >
    >
    >
    > Am 16.05.20, 09:05 schrieb "Christofer Dutz" <
    > christofer.dutz@c-ware.de>:
    >
    > Hi folks,
    >
    > let’s take discussions here :-)
    >
    > One thing I would like to point out, is that you should enable the
    > “with-sandbox” profile as one of the examples references a driver in the
    > sandbox which it can’t find if you don’t enable that.
    >
    > Chris
    >
    >
    >
    >
    >

Mime
View raw message