poi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 33681] - Cannot load 500kb file with usermodel or event model
Date Mon, 21 Feb 2005 23:53:59 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=33681>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=33681





------- Additional Comments From mserra@iwu.edu  2005-02-22 00:53 -------
I should add that I think the determining factor is not the file size, it is the
number of rows.  I can easily load a file with more total kb but fewer rows.
The file that will not load has over 1000 rows.

(In reply to comment #0)
> Whenever I try to load a simple, 500k file, I find that my CPU usage goes up to
> 98% and my memory slowly gets eaten... very slowly.  The file never loads.  But
> when I try to do this with a much smaller file (between 50-100k), I have no
> problems.  This happens regardless of whether I use the usermodel or the
> eventmodel.  Here is the code I am using for the usermodel:
> 
> public class LoadTest {
> 
>   public static void main(String[] args) {
> 
>     HSSFWorkbook workbook;
>     File inputFile = new File("big_test.xls");
>     try {
>     InputStream fileIn = new FileInputStream(inputFile);
>     fileIn = new BufferedInputStream(fileIn);
>     workbook = new HSSFWorkbook(fileIn);
>     fileIn.close();
>     } catch (FileNotFoundException ex) {
>     } catch (IOException ex) { }
>   }
> 
> }
> 
> And for the eventmodel, I am using the example from the HSSF howto homepage.
> It gets this far:
> 
> Encountered workbook
> New sheet named: Sheet1
> New sheet named: Sheet2
> New sheet named: Sheet3
> 
> And then it hangs the same way the usermodel did.
> I have also had this problem on a Windows XP box, and I've tried it with what
> appears to be a recent CVS build (poi-2.1-20050221).  It never works.  What is
> going on here?



-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: poi-dev-unsubscribe@jakarta.apache.org
Mailing List:    http://jakarta.apache.org/site/mail2.html#poi
The Apache Jakarta POI Project: http://jakarta.apache.org/poi/


Mime
View raw message