poi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Burch <n...@torchbox.com>
Subject Re: Getting "class file has wrong version" error on poi-scratchpad-3.0-rc2 jar
Date Mon, 02 Apr 2007 09:50:26 GMT
On Thu, 29 Mar 2007, David Fisher wrote:
> That class file was compiled with JDK 5.0
>
> See http://blogs.sun.com/sundararajan/entry/java_class_ic_errors

Bah, looks like a forgot to do a clean before doing a dist build. I find 
that despite telling eclipse to only use JDK 1.4 for poi, it still 
sometimes builds 1.5 classes :(

I've done a build of RC3, having done a clean. It's available from:
 	http://people.apache.org/~nick/POI-3.0-RC3/

Also, if no-one complains, I'm going to have the build ant task call the 
clean one early on, to prevent this happening again.

Nick

---------------------------------------------------------------------
To unsubscribe, e-mail: poi-dev-unsubscribe@jakarta.apache.org
Mailing List:    http://jakarta.apache.org/site/mail2.html#poi
The Apache Jakarta POI Project: http://jakarta.apache.org/poi/


Mime
View raw message