poi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yegor Kozlov <ye...@dinom.ru>
Subject OOXML branch and JDK 1.4
Date Fri, 12 Sep 2008 08:09:28 GMT
Hi All,

What the need to support jdk 1.4 in the OOXML branch is? What about making JDK 1.5 a minimum
requirement since POI 3.5?

Currently only ooxml code uses JDK 1.5 features. The OLE2 stuff is compatible with jdk 1.4.
That means we can't use 
enums, generics and other 1.5 features in HSSF and other OLE2 projects.

It's 2008. J2SE 1.4.2 will reach its End of Service Life in October 2008:

I think we can start using 1.5 features throughout the ooxml branch and, probably, in trunk.

If 1.4 compatibility is required, there are tools to convert 1.5 code into 1.4 compatible.
The most well-known is Retroweaver:

It operates by transforming Java class files compiled by a 1.5 compiler into class files which
can be run on an older 
virtual machine. Interestingly, other Apache projects already use Retroweaver, for example

What do people think?


To unsubscribe, e-mail: dev-unsubscribe@poi.apache.org
For additional commands, e-mail: dev-help@poi.apache.org

View raw message