poi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 45859] New: cloneSheet corrupts workbook with picture
Date Mon, 22 Sep 2008 13:17:28 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=45859

           Summary: cloneSheet corrupts workbook with picture
           Product: POI
           Version: 3.2-dev
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: normal
          Priority: P2
         Component: HSSF
        AssignedTo: dev@poi.apache.org
        ReportedBy: antti.koskimaki@joinex.com


Created an attachment (id=22622)
 --> (https://issues.apache.org/bugzilla/attachment.cgi?id=22622)
source and excel to re-produce the bug

I ran into mysterious workbook corrupts with recent POI releases. When opening
the workbook, excel (2003) complains

"File error, data may have been lost". After repairs all the formatting and
pictures seem to be lost.

I could narrow down the problem to

1) several cloneSheet operations
2) one worksheet having picture in it (not the cloned one)

See the attachment for excel and source to re-produce.

Removing the picture helps, and with single cloneSheet it works. Not all
pictures trigger the corrupt, and excel feedback varies based on picture too;
with some pictures I'll get multiple "File error" boxes, one for every sheet.
Or just one error box, like in attaced case.

Tested with several releases; r696898 (broken), r693085 (broken), r692893
(works), 3.1-FINAL (works) and 3.0.2-FINAL (works)


-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@poi.apache.org
For additional commands, e-mail: dev-help@poi.apache.org


Mime
View raw message