poi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christian Gosch" <christian.go...@inovex.de>
Subject RE: POI for Excel 2007 and JDK 1.4.x
Date Mon, 19 Apr 2010 15:15:49 GMT
The bad news about this topic is: There *are* systems out there which 
require JDK 1.4 and do not support newer JREs *although* the EOL time 
line.

And some people have to maintain them... 

And the owners usually do not plan to upgrade their system 
infrastructure "just because" there are some developers which would like 
to take advantage of newer libraries.

Thats the simple reality: They want MSO2007 on the front, but stay 
with lets says IBM WebSphere 6.0 in the backend.

Bad luck. Very bad luck. Legacy reality :-(

--cg


> -----Original Message-----
> From: Nick Burch [mailto:nick.burch@alfresco.com]
> Sent: Monday, April 19, 2010 12:15 PM
> To: POI Developers List
> Subject: Re: POI for Excel 2007 and JDK 1.4.x
> 
> On Sat, 17 Apr 2010, Abhay Chinnawar wrote:
> > Which version of POI supports Excel 2007 with JDK 1.4.x ?
> 
> None. If you want to use java 1.4, you can only use poi 3.2 on the 
older
> binary files
> 
> > Or does it works only with > JDK 1.5.x ?
> 
> Yes. You might be able to use it with retroweaver though, but given 
how
> long ago 1.4 was EOL'd, you should probably upgrade your JVM to 
something
> that's supported!
> 
> Nick
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@poi.apache.org
> For additional commands, e-mail: dev-help@poi.apache.org
> 
> 
> !DSPAM:4bcc2b7617321481423369!
> 
> 



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@poi.apache.org
For additional commands, e-mail: dev-help@poi.apache.org


Mime
View raw message