poi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 49138] New: Unit tests fail in Polish locale.
Date Fri, 16 Apr 2010 17:18:46 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=49138

           Summary: Unit tests fail in Polish locale.
           Product: POI
           Version: 3.7-dev
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: normal
          Priority: P2
         Component: POI Overall
        AssignedTo: dev@poi.apache.org
        ReportedBy: antoni.mylka@gmail.com


Created an attachment (id=25312)
 --> (https://issues.apache.org/bugzilla/attachment.cgi?id=25312)
Patch that fixes the issue for me.

This issue is about two related things:

1. A bug in PackagePropertiesPart.java, which makes the date properties be
extracted wrongly, the extracted java.util.Date instance refers to a different
timestamp than the original value in XML. I say the SimpleDateFormat instance
that is used to parse the datetime value from XML should have its timezone set
to GMT, otherwise the 'Z' from the XML is ignored and the value is interpreted
within the current timezone of the machine that runs the test. This is clearly
wrong.

2. Some unit tests make certain assumptions about the look of extracted
strings. These assumptions are wrong in Poland, and probably in other locales
outside the US.

Both of these cause the build to fail for me.

I'm talking about the current trunk, rev 934444

The attached patch fixes the issue for me.

I'm on windows xp with JDK 1.6.0_18 and and 1.7.1

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@poi.apache.org
For additional commands, e-mail: dev-help@poi.apache.org


Mime
View raw message