poi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 62187] Compiling with Java 10 fails with ClassCastException: org.apache.poi.openxml4j.util.ZipSecureFile$ThresholdInputStream cannot be cast to java.base/java.util.zip.ZipFile$ZipFileInputStream
Date Tue, 11 Sep 2018 19:26:51 GMT
https://bz.apache.org/bugzilla/show_bug.cgi?id=62187

--- Comment #15 from Greg Woolsey <greg.woolsey@gmail.com> ---
(In reply to Javed from comment #14)
> Hello, first of all i want to thank you all for your work.
> 
> I still have a problem, now the new version poi 4 is already released, but i
> am able to run my java-code on Java 10. I am getting a huge error, starting
> with:
> 
> Exception in thread "main" java.lang.NoClassDefFoundError:
> org/w3c/dom/ls/DocumentLS
> 	at java.base/java.lang.ClassLoader.defineClass1(Native Method)
> 
> I also tried to get along with the patch, but I still got an error -- So if
> you really managed to run the poi on java 10, could someone of you please,
> upload the jar files for me.
> 
> Thank you a lot.

This is unrelated to this issue.  That class is only found in older Xerces and
GWT-Dev jars [1], not any of the POI 4.0.0 dependencies or Java 8+. For
example, it was a core part of the JVM 15 years ago, per this bug reported as
fixed in Java 1.2 [2].

Check your classpath.

[1]
https://www.findjar.com/index.x;jsessionid=162736CF6358BCC23C85D4EBFD56D7D4?query=org.w3c.dom.ls.documentls
[2] https://bugs.openjdk.java.net/browse/JDK-4827955

-- 
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@poi.apache.org
For additional commands, e-mail: dev-help@poi.apache.org


Mime
View raw message