polygene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Niclas Hedhman <nic...@hedhman.org>
Subject API change suggestion
Date Tue, 06 Jun 2017 07:42:48 GMT
I have found a small annoying discrepancy;

interface PropertyDescriptor
interface AssociationDescriptor

shares a whole bunch of methods, which are in fact the same thing;

    QualifiedName qualifiedName();

    Type type();

    AccessibleObject accessor();

    boolean isImmutable();

    boolean queryable();

And in the Jooq ES, that I am working on, a great deal of duplication code
can be avoided if they shared a common super type.

I can't think of a good name for such super type, as StateDescriptor
already exists, which is an Composite level construct. We never really have
the equivalent of "fragments" for the
property/association/manyassociation/namedassociation concepts, as we
should have.

We could call it StateDescriptor and rename the current StateDescriptor,
which when I look at it doesn't have a totally solid name matching its


Niclas Hedhman, Software Developer
http://polygene.apache.org - New Energy for Java

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message