portals-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From woon...@apache.org
Subject svn commit: r1664028 - /portals/site/applications/src/site/xdoc/webcontent2/build-from-source.xml
Date Wed, 04 Mar 2015 14:57:52 GMT
Author: woonsan
Date: Wed Mar  4 14:57:51 2015
New Revision: 1664028

URL: http://svn.apache.org/r1664028
Log:
adding build-from-source and faq pages

Modified:
    portals/site/applications/src/site/xdoc/webcontent2/build-from-source.xml

Modified: portals/site/applications/src/site/xdoc/webcontent2/build-from-source.xml
URL: http://svn.apache.org/viewvc/portals/site/applications/src/site/xdoc/webcontent2/build-from-source.xml?rev=1664028&r1=1664027&r2=1664028&view=diff
==============================================================================
--- portals/site/applications/src/site/xdoc/webcontent2/build-from-source.xml (original)
+++ portals/site/applications/src/site/xdoc/webcontent2/build-from-source.xml Wed Mar  4 14:57:51
2015
@@ -65,15 +65,16 @@ $ mvn clean install
         <p>
           When you build from the trunk, the version of the modules installed in your local
maven repository
           will probably have '-SNAPSHOT' suffix. e.g, '2.0-SNAPSHOT'. You should use this
version number in dependencies.
-          However, if you want to use a different version number locally for some reason
(e.g, '2.0-dev' instead of '2.0-SNAPSHOT'),
+          However, if you want to use a different version number locally for some reason
+          (e.g, '2.0-r1649250' with a specific Subversion revision number instead of '2.0-SNAPSHOT'),
           then you might want to use
           <a href="http://mojo.codehaus.org/versions-maven-plugin/set-mojo.html">Versions
Maven Plugin</a>
           like the following example before building:
           <source><![CDATA[
-$ mvn versions:set -DnewVersion="2.0-dev"
+$ mvn versions:set -DnewVersion="2.0-r1649250"
 $ mvn clean install
           ]]></source>
-          <em>Note: </em>Do not change it to the official release version numbers
(e.g, 2.0, 2.0-rc1, etc.)
+          <em>Note: </em>Do not change it to the official release version numbers
(e.g, 2.0, 2.0-rc-1, 2.0-beta-1, etc.)
           because it can conflict with our official releases!
         </p>
       </subsection>



Mime
View raw message