portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raphaël Luta <raph...@apache.org>
Subject Re: Jetspeed LDAP (error)
Date Thu, 09 Mar 2006 15:41:01 GMT
Eivinn Hustveit wrote:
> Thanks Raphaël and Marky!
> 
> This almost worked... I tried to remove cn from MUST in core.schema  as
> well :
> 
> objectclass ( 2.5.6.17 NAME 'groupOfUniqueNames'
>         DESC 'RFC2256: a group of unique names (DN and Unique  Identifier)'
>         SUP top STRUCTURAL
>         MAY ( uniqueMember $ businessCategory $ cn $ seeAlso $ owner  $
> ou $ o $ description ) )
> 
> A group is then inserted into the LDAP directory (verified in 
> JXplorer). The problem now is that while Jetspeed list the group (ex: 
> ldap_admin_group), which I just created, it keep telling me that "The 
> group ldap_admin_group does not exist." when I try to add a user to  the
> group.
> 

If the group are keyed to uid in the DN, ie uid=mygroup, ou=groups. You need
to make sure the group objectClass will allow the uid attribute for this group.

You need to add uid in the MAY section of the group objectclass definition.

-- 
Raphaël Luta - raphael@apache.org
Apache Portals - Enterprise Portal in Java
http://portals.apache.org/

---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-dev-help@portals.apache.org


Mime
View raw message