portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ian Nicholls" <inicho...@gmail.com>
Subject Re: org.apache.velocity.tools.generic.ToolLoader no longer in Velocity as of 1.2
Date Sat, 27 May 2006 10:28:30 GMT
No it has not solved the problem, I have been fighting to get the
portal to work in my environment for about 5 days. I did a source
update this morening and a rebuild / deploy and then this error, so I
assumed I had gotten past the old problem but alas I have not.

Oh well back to the drawing board.

Ian

BTW I am getting this error as well......and this is the one I am
fighting with, If anyone has any ideas I would appreciate the help.

2006-05-27 15:41:38,173
[ContainerBackgroundProcessor[StandardEngine[Catalina]]] FATAL
org.apache.jetspeed.engine.JetspeedServlet - Jetspeed: init() failed:
org.apache.jetspeed.exception.JetspeedException: Jetspeed
Initialization exception!
        at org.apache.jetspeed.engine.JetspeedEngine.start(JetspeedEngine.java:131)
        at org.apache.jetspeed.engine.JetspeedServlet.init(JetspeedServlet.java:147)
        at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1091)
        at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:925)
        at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:3880)
        at org.apache.catalina.core.StandardContext.start(StandardContext.java:4141)
        at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:759)
        at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:739)
        at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:524)
        at org.apache.catalina.startup.HostConfig.deployDescriptor(HostConfig.java:603)
        at org.apache.catalina.startup.HostConfig.deployDescriptors(HostConfig.java:535)
        at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:470)
        at org.apache.catalina.startup.HostConfig.check(HostConfig.java:1181)
        at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:292)
        at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
        at org.apache.catalina.core.ContainerBase.backgroundProcess(ContainerBase.java:1304)
        at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.processChildren(ContainerBase.java:1568)
        at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.processChildren(ContainerBase.java:1577)
        at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.run(ContainerBase.java:1557)
        at java.lang.Thread.run(Thread.java:595)
Caused by: org.springframework.beans.factory.BeanCreationException:
Error creating bean with name 'java.util.prefs.PreferencesFactory'
defined in ServletContext resource [/WEB-INF/assembly/prefs.xml]:
Initialization of bean failed; nested exception is
org.apache.jetspeed.prefs.PreferencesException: Failed to initialize
prefs api.  java.lang.IllegalStateException: Failed to create new
Preferences of type 1 for path /
        at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:356)
        at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:260)
        at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:221)
        at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:145)
        at org.springframework.beans.factory.support.DefaultListableBeanFactory.preInstantiateSingletons(DefaultListableBeanFactory.java:291)
        at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:317)
        at org.springframework.web.context.support.AbstractRefreshableWebApplicationContext.refresh(AbstractRefreshableWebApplicationContext.java:131)
        at org.apache.jetspeed.components.SpringComponentManager.start(SpringComponentManager.java:217)
        at org.apache.jetspeed.engine.JetspeedEngine.start(JetspeedEngine.java:114)
        ... 19 more
Caused by: org.apache.jetspeed.prefs.PreferencesException: Failed to
initialize prefs api.  java.lang.IllegalStateException: Failed to
create new Preferences of type 1 for path /
        at org.apache.jetspeed.prefs.impl.PreferencesFactoryImpl.init(PreferencesFactoryImpl.java:74)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.invokeCustomInitMethod(AbstractAutowireCapableBeanFactory.java:1106)

On 5/27/06, Martin Dulisch <mdulisch@gmail.com> wrote:
> Hi Ian,
>
> I have the same problem. But the portal runs regardles of this exception.
>
> Please let me know if downgrading solves the problem.
>
> Martin
>
>
> 2006/5/27, Ian Nicholls <inicholls@gmail.com>:
> > Hi,
> >   I did an update from SVN today and now I get the following error
> >
> > _______________________________________________________________
> >
> > 2006-05-27 12:31:54,583 [main] INFO
> > org.apache.velocity.tools.view.servlet.ServletToolboxManager - Using
> > config file '/WEB-INF/toolbox.xml'
> > 2006-05-27 12:31:54,780 [main] ERROR
> > org.apache.velocity.tools.view.servlet.ServletToolboxManager - Problem
> > loading toolbox '/WEB-INF/toolbox.xml' :
> > java.lang.ClassNotFoundException:
> > org.apache.velocity.tools.generic.ToolLoader
> > 2006-05-27 12:31:54,782 [main] ERROR
> > org.apache.velocity.tools.view.servlet.ServletToolboxManager -
> > java.lang.ClassNotFoundException:
> > org.apache.velocity.tools.generic.ToolLoader
> >         at org.apache.commons.digester.Digester.createSAXException(Digester.java:2540)
> >         at org.apache.commons.digester.Digester.createSAXException(Digester.java:2566)
> >         at org.apache.commons.digester.Digester.endElement(Digester.java:1061)
> >         at org.apache.xerces.parsers.AbstractSAXParser.endElement(Unknown
> > Source)
> >
> >
> > _________________________________________________________________
> >
> > I did some research into the problem and this object has been
> > deprecated for a while and does not exist in the velocity-tools jar
> > file I have (Version 1.2).
> >
> > As A result of this I can no longer run the portal in my dev
> > environment. I am trying to down grade the version ofthe
> > velocity-tools to see if that fixes it without causing other problems.
> >
> > Ian
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
> > For additional commands, e-mail: jetspeed-dev-help@portals.apache.org
> >
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
> For additional commands, e-mail: jetspeed-dev-help@portals.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-dev-help@portals.apache.org


Mime
View raw message