portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dahl, Sandra" <SD...@TDIinc.com>
Subject RE: jetspeed tutorial error during build
Date Thu, 03 Sep 2009 19:38:28 GMT
Thanks for the suggestions. I have moved tomcat, eclipse workspace and maven outside of the
program files directory and they are located on c:\. I have also run with maven 2.0.10.

I have resolved many issues and this was showing the log:
Sep 3, 2009 8:42:43 AM org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting property 'source'
to 'org.eclipse.jst.jee.server:jetexpress' did not find a matching property

Along with this:
INFO: JetspeedContainerServlet: starting initialization of Portlet Application at: jetexpress-pa
Sep 3, 2009 11:22:20 AM org.apache.catalina.core.ApplicationContext log
INFO: JetspeedContainerServlet: Could not yet start portlet application at: jetexpress-pa.
Starting back ground thread to start when the portal comes online.

I read the SetPropertiesRule warning above may be fixed by running on Tomcat 6.0.14. After
trying this, the warning went away but the INFO messages still appear and the portal is not
started. There are no additional error or warning messages in the log files.

I'm wondering if I've missed a necessary step. The database I'm using is MS SqlServer and
the database is already seeded (the same database works running against the Jetspeed demo).
mvn jetspeed:mvn -Dtarget=all
is run, there is always an error in the database step and the script quits running.
mvn jetspeed:mvn -Dtarget=install runs successfully.
I then run
mvn jetspeed:mvn -Ddeploy-pa and deploy-portal

1. How can the create-schema.sql and drop-schema.sql scripts be replaced so target=all will
run without error?
2. How do I run all the steps in target=all except seeding the database?
3. Any other ideas on what is causing custom portal to not be deployed properly?

I don't know what else to try since there are no helpful messages in the log files.

-----Original Message-----
From: David Sean Taylor [mailto:d.taylor@onehippo.com]
Sent: Monday, August 31, 2009 5:17 PM
To: Jetspeed Developers List
Subject: Re: jetspeed tutorial error during build

On Aug 31, 2009, at 2:39 PM, Dahl, Sandra wrote:

> I am working through the jetspeed tutorial building jetexpress using
> java 1.6, m2eclipse and maven 2.2.1. I'm new to maven so please
> forgive me if this is easy to resolve and please let me know if you
> need additional information. The following error occurs when
> jetexpress project Is compiled:
> [INFO] Scanning for projects...
> [INFO] Reactor build order:
> [INFO]   jetexpress portal project
> [INFO]   jetexpress portal
> [INFO]   jetexpress portlet application
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Building jetexpress portal project
> [INFO]
> [INFO] Id: com.tdiinc:jetexpress:pom:0.0.1-SNAPSHOT
> [INFO] task-segment: [compile]
> [INFO]
> ------------------------------------------------------------------------
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Building jetexpress portal
> [INFO]
> [INFO] Id: com.tdiinc:jetexpress-portal:war:0.0.1-SNAPSHOT
> [INFO] task-segment: [compile]
> [INFO]
> ------------------------------------------------------------------------
> [INFO] [resources:resources]
> [INFO] Using default encoding to copy filtered resources.
> [INFO] [jetspeed-deploy:deploy]
> [INFO]
> [INFO]
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Reactor Summary:
> [INFO]
> ------------------------------------------------------------------------
> [INFO] jetexpress portal project .............................
> SUCCESS [0.000s]
> [INFO] jetexpress portal .....................................
> FAILED [0.891s]
> [INFO] jetexpress portlet application ........................ NOT
> [INFO]
> ------------------------------------------------------------------------
> The following mojo encountered an error while executing:
> Group-Id: org.apache.portals.jetspeed-2
> Artifact-Id: jetspeed-deploy-maven-plugin
> Version: 2.2.0
> Mojo: deploy
> brought in via: POM
> While building project:
> Group-Id: com.tdiinc
> Artifact-Id: jetexpress-portal
> Version: 0.0.1-SNAPSHOT
> From file: C:\Program Files\eclipse\workspace\jetexpress
> \__rootArtifactId__-portal\pom.xml
> Reason: Artifact org.apache.portals.jetspeed-2:jetspeed-layouts:war
> dependency not defined

I just tested it myself here, and (obviously, Im a committer) it
worked for me. I am trying to see  what is different, some

1. don't use C:\Program Files or any directly with spaces when using
Maven. It should work but personally I've never had much luck with it.
So just put your workspace and Tomcat in somewhere like /java/projects
or something similar

2. My Maven version is 2.0.10 -- I haven't tested the build against
the new 2.2 of Maven yet, it really shouldn't be a problem though

See if that helps if not we can look into  it deeper...

To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-dev-help@portals.apache.org

Email secured by Check Point

Confidentiality Notice:
The information contained in this communication, including attachments, is privileged and
confidential.  It is intended only for the exclusive use of the addressee.  If the reader
is not the intended recipient, or the employee, or the agent responsible for delivering it
to the intended recipient, you are hereby notified that any dissemination, distribution or
copying of this communication is strictly prohibited.  If you have received this communication
in error, please notify us by return email or telephone immediately.  Thank you.

To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-dev-help@portals.apache.org

View raw message