portals-wsrp4j-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexis BERNARD" <alexis_bern...@ds-fr.com>
Subject RE: org.apache.wsrp4j.exception.WSRPException: No message found in adding afifth TestPortlet to the SwingConsumer
Date Tue, 13 Jan 2004 13:47:25 GMT

I "only" added a new WSRPTestPortlet and not a new portlet. I did the
following :
I did the following :
- I modified the portletentityregistry.xml file located in C:\Tomcat
4.1\webapps\wsrp\WEB-INF\data by adding (for example) :
  <portlet id="3">
  <definition-id>wsrptest.WSRPTestPortlet</definition-id>
  </portlet>
in the <application id=99> markup of the default
portletentityregristry.xml.
I had to restart properly Tomcat.

- I added a
org.apache.wsrp4j.consumer.driver.WSRPPortletImpl@WSRP4J_99_3.xml file in
the driver\SwingConsumer\persistence\portlets directory with a similary
content to the other files. According to me, It makes the portlet known by
the swing Consumer.

- Lastly, to display the portlet, I added in the swing consumer, on the
same page than others, I added the portlet key in the
org.apache.wsrp4j.consumer.app.driver.PageImpl@WSRP4JTestPortlets.xml file
located in wsrp4j\driver\SwingConsumer\persistence\pages :
<portlet-key xsi:type="
java:org.apache.wsrp4j.consumer.driver.PortletKeyImpl" xmlns:xsi="
http://www.w3.org/2001/XMLSchema-instance">
  <portlet-handle>99.3</portlet-handle>
  <producer-id>1</producer-id>
  </portlet-key>

If you still have difficulties, watch a post of Julis McNaught which much
helped me (id:23).

Alexis.



|---------+------------------------------>
|         |           "ravishankar,      |
|         |           narayanan nair"    |
|         |           <ravishankar@crimso|
|         |           nlogic.com>        |
|         |                              |
|         |           01/13/2004 02:22 PM|
|         |           Veuillez répondre à|
|         |           wsrp4j-user        |
|         |                              |
|---------+------------------------------>
  >-----------------------------------------------------------------------------------------------------------------------|
  |                                                                                      
                                |
  |       Pour :    <wsrp4j-user@ws.apache.org>                                    
                                      |
  |       cc :      <alexis_bernard@ds-fr.com>                                     
                                      |
  |       Objet :   RE: org.apache.wsrp4j.exception.WSRPException: No message found in adding
afifth TestPortlet to the   |
  |        SwingConsumer                                                                 
                                |
  >-----------------------------------------------------------------------------------------------------------------------|




Hi Alexix,
Can you please let me know what is the procedure you have adopted? Any
links to documentation? I am trying to do the deployment in TOMCAT, but
not successful at all. Please help, thanks

Regards,
Rai

age-----
From: Alexis BERNARD [mailto:alexis_bernard@ds-fr.com]
Sent: Tuesday, January 13, 2004 9:02 PM
To: wsrp4j-user@ws.apache.org
Subject: Re: org.apache.wsrp4j.exception.WSRPException: No message found
in adding afifth TestPortlet to the SwingConsumer


Sorry, I solved my problem (the four portlets were displayed but not the
fifth). In fact, the batch file to restart Tomcat throwed a java
exception.
I had to restart it manually and it's worked.

Thank's


|---------+---------------------------->
|         |           Richard Jacob    |
|         |           <jacob@apache.org|
|         |           >                |
|         |                            |
|         |           01/13/2004 01:46 |
|         |           PM               |
|         |           Veuillez répondre|
|         |           à wsrp4j-user    |
|         |                            |
|---------+---------------------------->

>-----------------------------------------------------------------------
------------------------------------------------|
  |
|
  |       Pour :    wsrp4j-user@ws.apache.org
|
  |       cc :
|
  |       Objet :   Re: org.apache.wsrp4j.exception.WSRPException: No
message found in adding a fifth TestPortlet to the  |
  |        SwingConsumer
|

>-----------------------------------------------------------------------
------------------------------------------------|




Alexis BERNARD wrote:

>I restarted Tomcat stuff and it still doesn't work, so what is wrong in
my
>method?
>
>
>
The steps you take seem correct to me.
What exactly is being displayed? Do you see the other 4 portlets?
Is nothing displayed? Is there anything in the SwingConsumer log-file
indicating an error?
You could also check the TCP monitor for the getServiceDescription call
and its reply, is the 5th portlet contained in the portletDescription?

cu
Richard












Mime
View raw message