portals-wsrp4j-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthew J. Dovey" <matthew.do...@oucs.ox.ac.uk>
Subject RE: WSDL?
Date Wed, 24 Nov 2004 09:50:27 GMT
This is rapidly becoming a TFAQ (Too Frequently Asked Question).

The auto-generation of wsdl via Axis doesn't work. You shouldn't worry
too much about this as the WSRP services themselves work fine. I *think*
that this is a bug in Axis.

If you look in the wsrp Web directory you will find some static WSDL
files which you can use instead of the autogenerated ones if you need
WSDL (you may need to edit the endpoint URLs in these files).

Do any of the developers know what the particular Axis problem is and
whether this has been reported to Axis?

Matthew Dovey
Oxford University 

> -----Original Message-----
> From: denis queffeulou [mailto:denis.queffeulou@wokup.com] 
> Sent: 24 November 2004 09:42
> To: wsrp4j-user@ws.apache.org
> Subject: WSDL?
> 
> Hi,
> 
> I try the following URL :
> 
> http://localhost:8080/wsrp/services/WSRPServiceDescriptionService?wsdl
> 
> and the result is:
> 
> 
>     AXIS error
> 
> Sorry, something seems to have gone wrong... here are the details:
> 
> Exception - java.lang.reflect.InvocationTargetException
> 
> 
> 
>   WSRPServiceDescriptionService
> 
> Hi there, this is an AXIS service!
> 
> /Perhaps there will be a form for invoking the service here...
> 
> /I was expected a WSDL
> What can I do to resolve the problem ?
> 
> Thanks,
> 
> --
> Denis/
> 
> 
> /
> 

Mime
View raw message