portals-wsrp4j-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Norman Kubicek" <N.Kubi...@intershop.de>
Subject OASIS WSRP 1.0 schema definition and Axis 1.2 (Final)
Date Mon, 27 Jun 2005 09:15:47 GMT
Hallo,

has anybody already tried to use the OASIS WSRP v. 1.0 schema
definitions with Axis 1.2 (Final). The lib folder of the WSRP4J project
contains the JAR files of Axis 1.2 (Final), but the setcpath.bat file
still refers the old Axis JARs. (BTW: It is not possible to generate the
Java classes with the classpath entries currently used in the
setcpath.bat file.)

I run into the following problems using Axis 1.2 (Final) or 1.2.1
(Final):

wsdl2java
--------------
All Axis versions higher than 1.2RC3 do not generate a class for the
"ReturnAny" type. (Even if the wsdl2java parameter "-typeMappingVersion"
is set to "1.1") 

runtime
-----------
The following Axis exception occurs at runtime:

typeEntry:  null
 mode:       IN
 position:   0
 isReturn:   false
 typeQName:  {urn:oasis:names:tc:wsrp:v1:types}>initCookie
 javaType:   null
 inHeader:   false
 outHeader:  false
 java.lang.NoSuchMethodException:
org.apache.axis.encoding.ser.ArraySerializerFactory.create(java.lang.Cla
ss, javax.xml.namespace.QName)


Norman

Mime
View raw message