portals-wsrp4j-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kapil Bajaj <kapilba...@in.ibm.com>
Subject Re: proxyportlet issuse
Date Fri, 01 Jul 2005 05:12:52 GMT
Thanks for your response Meirong. I have sent you invitation for yahoo 
chat

Thanks and Regards
------------------------------------------------------------------------------------------------------------------
Kapil Bajaj




meirong liu <meirongl82@yahoo.com.cn> 
07/01/2005 08:57 AM
Please respond to
wsrp4j-user


To
wsrp4j-user@ws.apache.org
cc

Subject
proxyportlet issuse






Hi All 

I have just started to use WSRP4j .I m facing some problems in the normal 
instalation procedure as provided on 
  http://ws.apache.org/wsrp4j/gettingstarted/installation.html 
The problem is at 
step 3.Run the install-provider-pluto script (either sh or bat). . 

When I m runnng the script before installing the pluto portal it gives 
FileNotFound Exception for some mapping file. 
After installing the pluto portal and including the proxyportlet.jar in 
the class path error ocurrs at 

prepare web archive 'proxyportlet' ... 
org.exolab.castor.mapping.MappingException: The method 
getCastorResourceRefSet in class 
org.apache.pluto.portalImpl.om.servlet.impl.WebApplicationDefinitionImpl 
accepting/returning object of type interface java.util.Collection was not 
found 
        at 
org.exolab.castor.mapping.loader.MappingLoader.createFieldHandler(Unknown 
Source) 
        at 
org.exolab.castor.mapping.loader.MappingLoader.createFieldDesc(Unknown 
Source) 
        at org.exolab.castor.xml.XMLMappingLoader.createFieldDesc(Unknown 
Source) 
        at 
org.exolab.castor.mapping.loader.MappingLoader.createFieldDescs(Unknown 
Source) 
        at 
org.exolab.castor.mapping.loader.MappingLoader.createDescriptor(Unknown 
Source) 
        at org.exolab.castor.xml.XMLMappingLoader.createDescriptor(Unknown 
Source) 
        at 
org.exolab.castor.mapping.loader.MappingLoader.loadMapping(Unknown Source) 

        at org.exolab.castor.mapping.Mapping.getResolver(Unknown Source) 
        at org.exolab.castor.mapping.Mapping.getResolver(Unknown Source) 
        at org.exolab.castor.xml.Unmarshaller.setMapping(Unknown Source) 
        at org.exolab.castor.xml.Unmarshaller.<init>(Unknown Source) 
        at 
org.apache.pluto.portalImpl.Deploy.prepareWebArchive(Deploy.java:190) 
  &nbs p;     at org.apache.pluto.portalImpl.Deploy.main(Deploy.java:487) 
java.lang.Exception 
        at 
org.apache.pluto.portalImpl.Deploy.prepareWebArchive(Deploy.java:408) 
        at org.apache.pluto.portalImpl.Deploy.main(Deploy.java:487) 
 
I have just  provided the actual error that i m getting .So it would be 
helpful for me if anyone of you comes up with a solution for it. 
I think either some thing is buggy with the actual code provided or I am 
interpreiting something wrongly. 
Hope to see some solutions soon. 

Thanks and Regards
DO YOU YAHOO!?
雅虎免费G邮箱-中国第一绝无垃圾邮件骚扰超大邮箱 

Mime
View raw message