portals-wsrp4j-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vishal Goenka" <vgoe...@sungardsct.com>
Subject RE: Broken CVS and an unfrequently asked question
Date Wed, 29 Jun 2005 19:40:41 GMT
Julie, thanks for fixing it before I got a chance to notice. 

All, this is largely an mistake on my part. I submitted a patch for Axis 1.2
upgrade and while I had tested it before, I regenerated the Java code from
Axis to get a clean version, and did a diff against my working version.
Since outputs from the wsdl2java command do not match "exactly" from one run
to another (the ordering on certain variable assignments isn’t same from one
run to another) the diff is large and I did miss these one liner
replacements of the "return null" with the delegation to the WSRPEngine.
 
- Vishal

> -----Original Message-----
> From: Rickard Öberg [mailto:rickard@dreambean.com] 
> Sent: Tuesday, June 28, 2005 3:12 PM
> To: wsrp4j-user@ws.apache.org
> Subject: Re: Broken CVS and an unfrequently asked question
> 
> Julie MacNaught wrote:
> > The files are wrong.  I fixed them, but I didn't test them 
> completely, 
> > so if there are still issues, send another email.
> 
> Ok. It's a bit weird though, because this bug causes the 
> whole thing to not work, so I guess that means you didn't 
> test it at all? That's a bit worrying.
> 
> But what's more worrying, relly, is that this wasn't caught, 
> like, immediately. Is anyone using this stuff? Why didn't 
> loads of people scream and yell about it not working?!
> 
> >> * The FAQ says that this code should work on any portal 
> implementation.
> >> I've tried using the proxy portlet in our own portal code 
> and once I 
> >> got past the above issues it immediately crashed, and looking into 
> >> the code it has explicit dependencies on Pluto, i.e. 
> there's no way 
> >> it would ever work outside of Pluto. Is the FAQ incorrect, 
> or is the 
> >> dependency on Pluto a bug?
> > 
> > The dependency on Pluto is a known issue.
> 
> Ok. But then I would suggest that you change the FAQ because 
> as it is it's simply not true. I wasted lots of time 
> believing I could plug it in, as it says in the FAQ, and then 
> it turns out to be completely untrue.
> 
> >> I have many other minor and major issues with the code, 
> but these are 
> >> the two blockers for me so far. Any comments would be appreciated.
> > 
> > Feel free to consult http://issues.apache.org/jira/browse/WSRP4J
> > for known issues and/or create new ones.
> > 
> > If you find and fix any bugs, feel free to submit a patch. 
> We can use 
> > all the help we can get.
> 
> Will do.
> 
> If I sound grumpy it's only because I really really do want 
> WSRP to work well, and to some extent it hinges on WSRP4J 
> working decently, and so far my experience with it has been 
> miserable. Is this project supported by any company, or is it 
> more of a hobby project by individual developers? Any way is 
> ok, but it would be good to know.
> 
> /Rickard

Mime
View raw message