portals-wsrp4j-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Venkatesh Jayakumar" <venkatesh.jayaku...@northwestern.edu>
Subject RE: Error on accessing wsdl
Date Thu, 15 Jun 2006 17:02:54 GMT
Hi,

I deployed the testportlet and producer. I tried to access
http://localhost:8081/wsrp4j-producer/WSRP4JProducer/WSRPBaseService and it
says page cannot be displayed. Iam running my tomcat in port 8080

This is how my wsdl file looks like

<wsdl:service name="WSRPService">
        <wsdl:port binding="bind:WSRP_v1_Markup_Binding_SOAP"
name="WSRPBaseService">
            <soap:address
location="http://localhost:8081/wsrp4j-producer/WSRP4JProducer/WSRPBaseServi
ce"/>
        </wsdl:port>
        <wsdl:port binding="bind:WSRP_v1_ServiceDescription_Binding_SOAP"
name="WSRPServiceDescriptionService">
            <soap:address
location="http://localhost:8081/wsrp4j-producer/WSRP4JProducer/WSRPServiceDe
scriptionService"/>
        </wsdl:port>
        <wsdl:port binding="bind:WSRP_v1_Registration_Binding_SOAP"
name="WSRPRegistrationService">
            <soap:address
location="http://localhost:8081/wsrp4j-producer/WSRP4JProducer/WSRPRegistrat
ionService"/>
        </wsdl:port>
        <wsdl:port binding="bind:WSRP_v1_PortletManagement_Binding_SOAP"
name="WSRPPortletManagementService">
            <soap:address
location="http://localhost:8081/wsrp4j-producer/WSRP4JProducer/WSRPPortletMa
nagementService"/>
        </wsdl:port>
    </wsdl:service>
Any help please ?

Thanks.

Venkatesh Jayakumar 


-----Original Message-----
From: Manish Gupta [mailto:manish_guptaji@yahoo.com] 
Sent: Thursday, June 15, 2006 7:36 AM
To: wsrp4j-user@portals.apache.org
Subject: Re: Error on accessing wsdl

Yes, it is working now. Actually, I was earliar
commenting these tags only in one of the service and
not for others.

Thanks
Manish.


--- Kristofer Arnar Einarsson
<kristofer@kristofer.com> wrote:

> I found somewhere that this is an Axis but and
> "fixed" it by commenting 
> out typeMapping tags with ID, Handle and Key in
> server-config.wsdd
> 
> mbk / regards,
> Kristofer
> 
> 
> Manish Gupta wrote:
> > Hi,
> >  After deploying producer and test portlet in
> tomcat,
> > I am getting following error on accessing WSDL URL
> >
>
(http://localhost:8081/wsrp4j-producer/WSRP4JProducer/WSRPBaseService?wsdl)
> > 
> > AXIS error
> > 
> > Sorry, something seems to have gone wrong... here
> are
> > the details:
> > 
> > Fault - Bean attribute name is of type
> > java.lang.String, which is not a simple type
> > 
> > AxisFault
> >  faultCode:
> >
>
{http://schemas.xmlsoap.org/soap/envelope/}Server.generalException
> >  faultSubcode: 
> >  faultString: Bean attribute name is of type
> > java.lang.String, which is not a simple type
> >  faultActor: 
> >  faultNode: 
> >  faultDetail: 
> > 	{http://xml.apache.org/axis/}hostname:prasad
> > 
> > 
> > Can somebody help me?
> > 
> > Regards
> > Manish.
> > 
> > 
> > 
> > __________________________________________________
> > Do You Yahoo!?
> > Tired of spam?  Yahoo! Mail has the best spam
> protection around 
> > http://mail.yahoo.com 
> 


__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 



Mime
View raw message