portals-wsrp4j-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris.DeBr...@perficient.com
Subject Getting Started
Date Tue, 13 Jun 2006 15:26:50 GMT
I'm looking at a project where the customer would like to leverage WSRP
using a BEA WebLogic consumer with a producer running off Tomcat.
<br><br>I've finally built the latest source with Maven 2.0.4, but am
having trouble getting the SwingConsumer to run as there is no main
class. Any suggestions there?
<br><br>I've also downloaded the 052005_wsrp_webapps.zip from the Wiki page and
am getting the following exception report from wsrptest:
<br><br><font face="monospace" size="3">javax.servlet.ServletException:
Wrapper cannot find servlet class org.apache.pluto.core.PortletServlet or a class it depends
on<br>org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)<br>org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)<br>org.apache.coyote.http11.Http11AprProcessor.process(Http11AprProcessor.java:833)<br>org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.process(Http11AprProtocol.java:639)<br>org.apache.tomcat.util.net.AprEndpoint$Worker.run(AprEndpoint.java:1285)<br>&nbsp;&nbsp;
&nbsp;&nbsp; java.lang.Thread.run(Unknown Source)<br><br><span style="font-family:
Verdana,Arial,Helvetica,sans-serif;">Pluto is in webapps along with proxyportlet and wsrp,
so I'm not sure what may be wrong.<br><br>After copying pluto-portal-1.0.1.jar
to the lib folder of wsrptest, the error message went away, but now it complaisn that WSRP
TestPortlet is not available.<br></span><br style="font-family: Verdana,Arial,Helvetica,sans-serif;"></font>Any
assistance is appreciated. 
<br><br>Thanks,
<br><br>Chris
<br>
Mime
View raw message