portals-wsrp4j-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alpha Juniper" <alpha.juni...@gmail.com>
Subject unsubscribe
Date Tue, 27 Jun 2006 06:47:25 GMT
unsubscribe





On 6/27/06, Venkatesh Jayakumar <venkatesh.jayakumar@northwestern.edu>
wrote:
>
> Thanks Kristofer,
> Iam getting this error when trying to consume the wsrp4j-testportlet.
> Donno
> How to get over it.
>
> Iam using tomcat-5.5.17 with the latest version of wsr4j.
>
> - ServletContext '/wsrp4j-testportlet' not found!
> - PortletInvokerImpl.action() - Unable to find RequestDispatcher.
> - Call of portletService() failed!
> javax.portlet.PortletException: Unable to find dispatcher for context:
> wsrp4j pr
> oducer
>         at
> org.apache.pluto.invoker.impl.PortletInvokerImpl.invoke(PortletInvoke
> rImpl.java:166)
>         at
> org.apache.pluto.invoker.impl.PortletInvokerImpl.render(PortletInvoke
> rImpl.java:73)
>
> Thanks,
> Venkatesh.
> -----Original Message-----
> From: Kristofer Arnar Einarsson [mailto:kristofer@kristofer.com]
> Sent: Saturday, June 17, 2006 6:54 AM
> To: wsrp4j-user@portals.apache.org
> Subject: Re: Error on accessing wsdl
>
> Did you change localhost:8081 to the hostname:8081 in the service file
> and the properties file?
>
> mbk / regards,
> Kristofer
>
>
> Venkatesh Jayakumar wrote:
> > Hi Manish,
> >
> > You are right my webapp context was wrong, now Iam able to access the
> > Baseservice and the 4 urls.
> >
> > Thanks for the help.
> >
> > Now I have bigger problems. Iam using Oracle portal to consume the
> portlet
> > which expects a WSDL but it is failing to consume saying that
> >
> > An error occurred during the call to the WSRP Provider:
> > java.rmi.RemoteException: Runtime exception; nested exception is:
> > unexpected element name: expected=,
> > actual={http://xml.apache.org/axis/}hostname
> > Java stack trace from root exception:
> > unexpected element name: expected=,
> > actual={http://xml.apache.org/axis/}hostname
> > at
> >
>
> oracle.webdb.wsrp.WSRP_v1_ServiceDescription_PortType_getServiceDescription
> _
> >
>
> Fault_SOAPSerializer.deserializeDetail(WSRP_v1_ServiceDescription_PortType_g
> > etServiceDescription_Fault_SOAPSerializer.java:68)
> > at
> >
> com.sun.xml.rpc.encoding.SOAPFaultInfoSerializer.doDeserialize
> (SOAPFaultInfo
> > Serializer.java:81)
> > at
> >
> com.sun.xml.rpc.encoding.ObjectSerializerBase.deserialize
> (ObjectSerializerBa
> > se.java:165)
> > at
> >
> com.sun.xml.rpc.encoding.ReferenceableSerializerImpl.deserialize
> (Referenceab
> > leSerializerImpl.java:115)
> > at
> >
>
> oracle.webdb.wsrp.WSRP_v1_ServiceDescription_PortType_Stub._readBodyFaultEle
> > ment(WSRP_v1_ServiceDescription_PortType_Stub.java:131)
> > at com.sun.xml.rpc.client.StreamingSender._send(StreamingSender.java
> :179)
> > at
> >
>
> oracle.webdb.wsrp.WSRP_v1_ServiceDescription_PortType_Stub.getServiceDescrip
> > tion(WSRP_v1_ServiceDescription_PortType_Stub.java:63)
> > at
> >
>
> oracle.webdb.wsrp.client.design.v1.OraWSRP_v1_ServiceDescription_PortType.ge
> > tServiceDescription(Unknown Source)
> > . (WWC-43273)
> >
> > Venkatesh Jayakumar
> >
> >
> > -----Original Message-----
> > From: Manish Gupta [mailto:manish_guptaji@yahoo.com]
> > Sent: Thursday, June 15, 2006 10:17 PM
> > To: wsrp4j-user@portals.apache.org
> > Subject: RE: Error on accessing wsdl
> >
> > Hi Venkatesh,
> >  Are you sure that your producer webapp context is
> > wsrp4j-producer?? Can you also check your catlina log
> > for any exception during producer deployment?
> > By the way, how did you got this wsdl, if you are not
> > able to access your producer?
> >
> > Thanks
> > Manish.
> >
> > --- Venkatesh Jayakumar
> > <venkatesh.jayakumar@northwestern.edu> wrote:
> >
> >> Hi,
> >>
> >> I deployed the testportlet and producer. I tried to
> >> access
> >>
> > http://localhost:8081/wsrp4j-producer/WSRP4JProducer/WSRPBaseService
> >> and it
> >> says page cannot be displayed. Iam running my tomcat
> >> in port 8080
> >>
> >> This is how my wsdl file looks like
> >>
> >> <wsdl:service name="WSRPService">
> >>         <wsdl:port
> >> binding="bind:WSRP_v1_Markup_Binding_SOAP"
> >> name="WSRPBaseService">
> >>             <soap:address
> >>
> >
> location="
> http://localhost:8081/wsrp4j-producer/WSRP4JProducer/WSRPBaseServi
> >> ce"/>
> >>         </wsdl:port>
> >>         <wsdl:port
> >>
> > binding="bind:WSRP_v1_ServiceDescription_Binding_SOAP"
> >> name="WSRPServiceDescriptionService">
> >>             <soap:address
> >>
> >
> location="
> http://localhost:8081/wsrp4j-producer/WSRP4JProducer/WSRPServiceDe
> >> scriptionService"/>
> >>         </wsdl:port>
> >>         <wsdl:port
> >> binding="bind:WSRP_v1_Registration_Binding_SOAP"
> >> name="WSRPRegistrationService">
> >>             <soap:address
> >>
> >
> location="
> http://localhost:8081/wsrp4j-producer/WSRP4JProducer/WSRPRegistrat
> >> ionService"/>
> >>         </wsdl:port>
> >>         <wsdl:port
> >>
> > binding="bind:WSRP_v1_PortletManagement_Binding_SOAP"
> >> name="WSRPPortletManagementService">
> >>             <soap:address
> >>
> >
> location="
> http://localhost:8081/wsrp4j-producer/WSRP4JProducer/WSRPPortletMa
> >> nagementService"/>
> >>         </wsdl:port>
> >>     </wsdl:service>
> >> Any help please ?
> >>
> >> Thanks.
> >>
> >> Venkatesh Jayakumar
> >>
> >>
> >> -----Original Message-----
> >> From: Manish Gupta [mailto:manish_guptaji@yahoo.com]
> >>
> >> Sent: Thursday, June 15, 2006 7:36 AM
> >> To: wsrp4j-user@portals.apache.org
> >> Subject: Re: Error on accessing wsdl
> >>
> >> Yes, it is working now. Actually, I was earliar
> >> commenting these tags only in one of the service and
> >> not for others.
> >>
> >> Thanks
> >> Manish.
> >>
> >>
> >> --- Kristofer Arnar Einarsson
> >> <kristofer@kristofer.com> wrote:
> >>
> >>> I found somewhere that this is an Axis but and
> >>> "fixed" it by commenting
> >>> out typeMapping tags with ID, Handle and Key in
> >>> server-config.wsdd
> >>>
> >>> mbk / regards,
> >>> Kristofer
> >>>
> >>>
> >>> Manish Gupta wrote:
> >>>> Hi,
> >>>>  After deploying producer and test portlet in
> >>> tomcat,
> >>>> I am getting following error on accessing WSDL
> >> URL
> >
> (http://localhost:8081/wsrp4j-producer/WSRP4JProducer/WSRPBaseService?wsdl
> )
> >>>> AXIS error
> >>>>
> >>>> Sorry, something seems to have gone wrong...
> >> here
> >>> are
> >>>> the details:
> >>>>
> >>>> Fault - Bean attribute name is of type
> >>>> java.lang.String, which is not a simple type
> >>>>
> >>>> AxisFault
> >>>>  faultCode:
> >>>>
> > {http://schemas.xmlsoap.org/soap/envelope/}Server.generalException
> >>>>  faultSubcode:
> >>>>  faultString: Bean attribute name is of type
> >>>> java.lang.String, which is not a simple type
> >>>>  faultActor:
> >>>>  faultNode:
> >>>>  faultDetail:
> >>>>    {http://xml.apache.org/axis/}hostname:prasad
> >>>>
> >>>>
> >>>> Can somebody help me?
> >>>>
> >>>> Regards
> >>>> Manish.
> >>>>
> >>>>
> >>>>
> >>>>
> >> __________________________________________________
> >>>> Do You Yahoo!?
> >>>> Tired of spam?  Yahoo! Mail has the best spam
> >>> protection around
> >>>> http://mail.yahoo.com
> >>
> >> __________________________________________________
> >> Do You Yahoo!?
> >> Tired of spam?  Yahoo! Mail has the best spam
> >> protection around
> >> http://mail.yahoo.com
> >>
> >>
> >>
> >
> >
> > __________________________________________________
> > Do You Yahoo!?
> > Tired of spam?  Yahoo! Mail has the best spam protection around
> > http://mail.yahoo.com
> >
> >
>
>
>

Mime
View raw message