portals-wsrp4j-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Spies, Brennan" <Brennan.Sp...@ejgallo.com>
Subject RE: Compile from SVN trunk Test failure
Date Thu, 09 Oct 2008 16:40:17 GMT
I double-checked the validation in Eclipse with a dummy
applicationContext.xml, and it should work. Seems to work for either 2.0 or
2.5 of the spring-aop.xsd, but I would change it to 2.5 just in case.

 

You may be having a problem similar to this one:
http://forum.springframework.org/showthread.php?t=35417

 

Not sure why a CNFE would result in an XML parser error, but this should be
an easy one to troubleshoot in this case. In Eclipse with the m2eclipse
plugin, pull up your pom.xml in the POM editor. On the Dependency Hierarchy
or Dependency Graph tabs, you should be able to see spring-aop-2.5.jar. If
you don't, add it as a dependency. You may want to do an "mvn clean" prior to
running the build just to make sure.

 

From: Ian O' Keeffe [mailto:okeeffe.ian@gmail.com] 
Sent: Thursday, October 09, 2008 8:15 AM
To: wsrp4j-user@portals.apache.org
Subject: Re: Compile from SVN trunk Test failure

 

Hi Brennan,

My initial testing was done on a machine behind a proxy. However I have
reproduced this error on a machine that is not behind a proxy. 

I was also able to follow the network traffic coming from my machine as
tomcat started. This allowed me to verify that a request was being made to
get the AOP schema file and that the file was being retrieved correctly.

Thanks again for your suggestions.

Ian

2008/10/8 Spies, Brennan <Brennan.Spies@ejgallo.com>

Is your Internet access through a proxy server?

 

From: Ian O' Keeffe [mailto:okeeffe.ian@gmail.com] 
Sent: Wednesday, October 08, 2008 1:50 AM


To: wsrp4j-user@portals.apache.org

Subject: Re: Compile from SVN trunk Test failure

 

Hi Brennan,

Thanks for your suggestion but that was the first thing I checked. 

Here are some snippets from the applicationContext.xml file:

<beans xmlns="http://www.springframework.org/schema/beans"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xmlns:context="http://www.springframework.org/schema/context"
    xmlns:aop="http://www.springframework.org/schema/aop"
    xsi:schemaLocation="http://www.springframework.org/schema/beans 
    http://www.springframework.org/schema/beans/spring-beans-2.5.xsd
    http://www.springframework.org/schema/context
    http://www.springframework.org/schema/context/spring-context-2.5.xsd
    http://www.springframework.org/schema/aop 
    http://www.springframework.org/schema/aop/spring-aop-2.0.xsd">

...
<bean id="ProducerConfiguration" 
 
class="org.apache.wsrp4j.commons.util.configuration.ProducerConfiguration"
        scope="session">        
        <aop:scoped-proxy/>        
    </bean>

...

</beans>

Perhaps I've missed something but the namespace declarations seem to be okay.

Thanks for your help,

Ian

2008/10/7 Spies, Brennan <Brennan.Spies@ejgallo.com>

Ian,

 

I am not a developer on the project, but I'll take a stab. Not looking at the
source (which I don't have the source on my box), it looks like the
validating parser is not able to find the element in the "aop" namespace...

 

Does the Spring xml file contain something like the following...(look for:
the "spring-aop-x.x.xsd")?

 

<?xml version="1.0" encoding="UTF-8"?>

<beans xmlns="http://www.springframework.org/schema/beans"

           xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

           xmlns:aop="http://www.springframework.org/schema/aop"

           xmlns:tx="http://www.springframework.org/schema/tx"

           xsi:schemaLocation="

http://www.springframework.org/schema/beans
http://www.springframework.org/schema/beans/spring-beans-2.5.xsd

http://www.springframework.org/schema/tx
http://www.springframework.org/schema/tx/spring-tx-2.5.xsd

http://www.springframework.org/schema/aop
http://www.springframework.org/schema/aop/spring-aop-2.5.xsd">

 

 

From: Ian O' Keeffe [mailto:okeeffe.ian@gmail.com] 
Sent: Monday, October 06, 2008 1:48 PM
To: wsrp4j-user@portals.apache.org
Subject: Compile from SVN trunk Test failure

 

Hi,

Today I tried to upgrade to the latest version of WSRP4J by compiling from
the trunk. The compilation was successful but there was 1 test failure when
packaging persistence-db. I skipped this failure by running mvn -fn (probably
a bad thing to do but I was hoping I wouldn't need that part of wsrp4j). 

When I installed wsrp4j-producer the webapp wouldn't start. Instead I got
this error:

SEVERE: Context initialization failed
org.springframework.beans.factory.xml.XmlBeanDefinitionStoreException: Line
195 in XML document from class path resource [applic
ationContext.xml] is invalid; nested exception is
org.xml.sax.SAXParseException: cvc-complex-type.2.4.c: The matching wildcard
i
s strict, but no declaration can be found for element 'aop:scoped-proxy'.
        at
org.springframework.beans.factory.xml.XmlBeanDefinitionReader.doLoadBeanDefin
itions(XmlBeanDefinitionReader.java:404)
        at
org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinit
ions(XmlBeanDefinitionReader.java:342)
        at
org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinit
ions(XmlBeanDefinitionReader.java:310)
        at
org.springframework.beans.factory.support.AbstractBeanDefinitionReader.loadBe
anDefinitions(AbstractBeanDefinitionReader.java:143)
        at
org.springframework.beans.factory.support.AbstractBeanDefinitionReader.loadBe
anDefinitions(AbstractBeanDefinitionReader.java:178)
        at
org.springframework.beans.factory.support.AbstractBeanDefinitionReader.loadBe
anDefinitions(AbstractBeanDefinitionReader.java:149)
        at
org.springframework.web.context.support.XmlWebApplicationContext.loadBeanDefi
nitions(XmlWebApplicationContext.java:124)
        at
org.springframework.web.context.support.XmlWebApplicationContext.loadBeanDefi
nitions(XmlWebApplicationContext.java:92)
        at
org.springframework.context.support.AbstractRefreshableApplicationContext.ref
reshBeanFactory(AbstractRefreshableApplicationContext.java:123)
        at
org.springframework.context.support.AbstractApplicationContext.obtainFreshBea
nFactory(AbstractApplicationContext.java:423)
        at
org.springframework.context.support.AbstractApplicationContext.refresh(Abstra
ctApplicationContext.java:353)
        at
org.springframework.web.context.ContextLoader.createWebApplicationContext(Con
textLoader.java:255)
        at
org.springframework.web.context.ContextLoader.initWebApplicationContext(Conte
xtLoader.java:199)
        at
org.springframework.web.context.ContextLoaderListener.contextInitialized(Cont
extLoaderListener.java:45)
        at
org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:3
763)
        at
org.apache.catalina.core.StandardContext.start(StandardContext.java:4211)
        at
org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:75
9)
        at
org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:739)
        at
org.apache.catalina.core.StandardHost.addChild(StandardHost.java:524)
        at
org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:809)
        at
org.apache.catalina.startup.HostConfig.deployWARs(HostConfig.java:698)
        at
org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:472)

I'm guessing that it either has to do with SAX being unable to retrieve the
xsl although the import in applicationContext.xml looks fine or, as I read on
one forum, to do with aop not being on the class path.

Can anybody shed any light on this issue.

Thanks in advance,

Ian

 

 


Mime
View raw message