pulsar-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Apache Pulsar Slack" <apache.pulsar.sl...@gmail.com>
Subject Slack digest for #general - 2019-01-21
Date Mon, 21 Jan 2019 09:11:02 GMT
2019-01-20 14:38:23 UTC - Jason: @Jason has joined the channel
----
2019-01-21 00:42:02 UTC - Alex Mault: Hi All. It appears that the latest version of Pulsar’s
python client in PyPi (2.2.1)  has not been built to work with OSX. The newest version available
to pip on osx is 2.0.1
----
2019-01-21 00:42:57 UTC - Matteo Merli: which macos version?
----
2019-01-21 00:43:38 UTC - Alex Mault: 10.14.2
----
2019-01-21 00:43:48 UTC - Matteo Merli: <https://pypi.org/project/pulsar-client/#files>
----
2019-01-21 00:44:15 UTC - Matteo Merli: there are binaries for Python 2.7 and 3.7 on MacOS
10.12, 10.13 and 10.14
----
2019-01-21 00:44:56 UTC - Alex Mault: @Matteo Merli Yea, for whatever reason it’s not picked
up. Do you have an OSX 10.14.2 machine available? If so, give `pip -v install pulsar-client==2.2.1`
a run and you’ll see it ignore the bundle.
----
2019-01-21 00:45:08 UTC - Alex Mault: (otherwise, one moment while I get the output pasted)
----
2019-01-21 00:46:25 UTC - Matteo Merli: I’m on 10.14.1 though that shouldn’t affect the
`pip install` logic
----
2019-01-21 00:46:40 UTC - Alex Mault: <https://gist.github.com/AlJaMa/7d9f88a3aaca2b2f49338d8fcbe8afc5>
----
2019-01-21 01:17:48 UTC - Alex Mault: @Matteo Merli oh I see. I missed the fact that it is
compiled for python 3.7 only for osx 10.14.x
----
2019-01-21 01:18:51 UTC - Alex Mault: Is there a reason it’s 3.7 only? Python 3.7 doesn’t
ship with MacOS 10.14 by default to my knowledge. (Only 3.6 does iirc)
----
2019-01-21 01:19:49 UTC - Matteo Merli: We have 2.7 and 3.7.

MacOS comes only with 2.7, though homebrew ships 3.7
----
2019-01-21 01:25:40 UTC - Alex Mault: Wow, guess I just haven’t updated my python3 via homebrew
in some time. Sorry for the confusion and thank you for the help :slightly_smiling_face:
----
2019-01-21 01:25:53 UTC - Matteo Merli: No problem :slightly_smiling_face:
----
2019-01-21 01:26:27 UTC - Alex Mault: @Matteo Merli For what it’s worth OS X 10.14 now does
come with 3.6 installed by default
----
2019-01-21 01:26:34 UTC - Alex Mault: ``` which python3
/Library/Frameworks/Python.framework/Versions/3.6/bin/python3```
----
2019-01-21 03:52:34 UTC - Samuel Sun: Hi , one question about pulsar code, relevant zookeeper
tools.
----
2019-01-21 03:54:01 UTC - Samuel Sun: there is a <https://github.com/apache/pulsar/blob/master/pulsar-broker/src/main/java/org/apache/pulsar/broker/namespace/ServiceUnitZkUtils.java>
 under the folder namespaces ? any reason we don’t put it under the pulsar-broker/utils
.
----
2019-01-21 04:03:06 UTC - Ali Ahmed: @Alex Mault I see ```
/usr/bin/python -V
Python 2.7.10
```
----
2019-01-21 04:08:23 UTC - Alex Mault: @Ali Ahmed yea, I believe python2.7 is still default
on MacOS. Could you run ‘which python3’ ? 
----
2019-01-21 04:09:14 UTC - Ali Ahmed: I have a brew python3 package i don’t think mojave
comes with any python3 package by default
----
2019-01-21 04:10:31 UTC - Alex Mault: Anything at /Library/Frameworks/Python.framework/Versions/3.6/bin/python3
----
2019-01-21 04:10:32 UTC - Alex Mault: ?
----
2019-01-21 04:11:02 UTC - Ali Ahmed: no
```
ll /Library/Frameworks/
total 0
drwxr-xr-x   9 root  wheel   288B Jan 15 17:30 .
drwxr-xr-x+ 66 root  wheel   2.1K Oct 11 18:41 ..
lrwxr-xr-x   1 root  wheel    71B Oct  3 18:51 AEProfiling.framework -&gt; ../../Applications/Motion.app/Contents/Frameworks/AEProfiling.framework
lrwxr-xr-x   1 root  wheel    74B Oct  3 18:51 AERegistration.framework -&gt; ../../Applications/Motion.app/Contents/Frameworks/AERegistration.framework
lrwxr-xr-x   1 root  wheel    74B Oct  3 18:51 AudioMixEngine.framework -&gt; ../../Applications/Motion.app/Contents/Frameworks/AudioMixEngine.framework
lrwxr-xr-x   1 root  wheel    60B Oct  3 18:51 NyxAudioAnalysis.framework -&gt; /System/Library/PrivateFrameworks/NyxAudioAnalysis.framework
drwxr-xr-x   6 root  wheel   192B Jan 15 17:30 OSXFUSE.framework
drwxr-xr-x   5 root  wheel   160B Oct  3 18:58 PluginManager.framework
lrwxr-xr-x@  1 root  wheel    50B Oct  3 18:51 iTunesLibrary.framework -&gt; /System/Library/Frameworks/iTunesLibrary.framework
```
----
2019-01-21 04:13:34 UTC - Alex Mault: Huh, I guess I am going crazy. Thanks for digging into
this with me.
----
2019-01-21 06:27:59 UTC - Samuel Sun: and also we import the zkUtils from bookeeper ? is it
a little messed ?
----
2019-01-21 07:01:28 UTC - bossbaby: how to prevent topic not delete when new broker in people
unknow connect to cluster?
----
Mime
View raw message