pulsar-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Apache Pulsar Slack" <apache.pulsar.sl...@gmail.com>
Subject Slack digest for #general - 2019-01-26
Date Sat, 26 Jan 2019 09:11:02 GMT
2019-01-25 15:49:48 UTC - Grant Wu: I’m not actually a C++ developer, but from what I’ve
heard from people who are, there’s nothing trivial about compiling something written for
Linux on Windows, if the application is nontrivial.  “Standard C++” doesn’t necessarily
mean anything.
----
2019-01-25 15:50:44 UTC - Grant Wu: If “standard C++” meant what we would like it to mean,
it wouldn’t have taken Chrome multiple years to switch compilers.  And Pulsar would be trivially
buildable upon musl.
----
2019-01-25 17:05:34 UTC - Matteo Merli: @dba @Grant Wu I think that compiling on Windows shouldn’t
be that bad.

We don’t use any linux/posix APIs directly, rather we rely on libraries that are already
multi-platform (eg: boost::asio for the networking code).

In that sense, we’re using “standard C++” :slightly_smiling_face:

Also, we use CMake to compile which is well supported on Windows.

I wouldn’t expect more than a few fixes on the compile script to get everything working
on Windows.

Having said that, I think most committers are not familiar with Windows or have access to
a Windows machine, so that complicates things.

If anyone with Windows experience is willing to try it out, we will sure make everything to
help out removing roadblocks!
----
2019-01-25 23:55:32 UTC - Ambud Sharma: is it possible to deploy bookkeeper with a custom
root znode?
----
2019-01-25 23:57:29 UTC - Matteo Merli: Sure you just have to pass `zkServers=my-zk1:2181/my-prefix-path`
----
2019-01-25 23:58:02 UTC - Matteo Merli: (Though same prefix should be used for Pulsar broker
too)
----
2019-01-25 23:59:41 UTC - Matteo Merli: That’s because the BK client running in broker is
sharing the same `zookeeperServers=` option in `broker.conf`
----
2019-01-26 00:02:57 UTC - Ambud Sharma: @Matteo Merli thanks, we did that but the bookies
are failing to start. Here are the steps I followed:
1. created 3 node bk cluster
2. used /devpulsar suffix on zkServers (same for brokers and bookies)
3. Initialized cluster metadata
4. Tried to start bookie but fails
can re-create this scenario and DM you the error
----
2019-01-26 00:03:39 UTC - Ambud Sharma: running it without the root znode worked
----
2019-01-26 00:03:57 UTC - Matteo Merli: Did you pass the same prefix when running initialize-cluster-metadata
?
----
2019-01-26 00:04:10 UTC - Ambud Sharma: yes
----
2019-01-26 00:04:28 UTC - Matteo Merli: Ok, then, please share the errors :slightly_smiling_face:
----
Mime
View raw message