qpid-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From acon...@apache.org
Subject [qpid-proton] branch go1 updated: PROTON-2017: [go] fix proton-c version check
Date Thu, 07 Mar 2019 18:37:46 GMT
This is an automated email from the ASF dual-hosted git repository.

aconway pushed a commit to branch go1
in repository https://gitbox.apache.org/repos/asf/qpid-proton.git


The following commit(s) were added to refs/heads/go1 by this push:
     new 7bf9256  PROTON-2017: [go] fix proton-c version check
7bf9256 is described below

commit 7bf92569070b69a52dc8ff2cf0c2635e9d5bbf3a
Author: Alan Conway <aconway@redhat.com>
AuthorDate: Thu Mar 7 13:34:43 2019 -0500

    PROTON-2017: [go] fix proton-c version check
---
 amqp/version.go | 10 ++++++----
 1 file changed, 6 insertions(+), 4 deletions(-)

diff --git a/amqp/version.go b/amqp/version.go
index 31d69d2..f770d08 100644
--- a/amqp/version.go
+++ b/amqp/version.go
@@ -22,14 +22,16 @@ under the License.
 // Update the generator and re-run if you need to modify this code.
 //
 
-
 package amqp
 
-// Version check for proton library.
-// Done here because this is the lowest-level dependency for all the proton Go packages.
+// Version check for compatible proton-c library.
+//
+// NOTE: the required version should NOT be increased unless the Go
+// library is modified to require some new proton-c API. That hasn't
+// happened for a long time.
 
 // #include <proton/version.h>
-// #if PN_VERSION_MAJOR == 0 && PN_VERSION_MINOR < 27
+// #if PN_VERSION_MAJOR == 0 && PN_VERSION_MINOR < 10
 // #error packages qpid.apache.org/... require Proton-C library version 0.10 or greater
 // #endif
 import "C"


---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@qpid.apache.org
For additional commands, e-mail: commits-help@qpid.apache.org


Mime
View raw message