qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kim van der Riet <kim.vdr...@redhat.com>
Subject Heads up: Multiple AMQP version support code changes for Java
Date Fri, 08 Sep 2006 20:46:51 GMT
I am working to add support on the broker for multiple versions of the
AMQP protocol for both C++ and Java. This is not a simple change to
make, and I am tackling this in stages. The first part of the Java
implementation is now complete, and has been checked into subversion as
ver. 507. This is a summary of the changes:

1. The Ant build system is now AMQP version-aware, and reads the major
and minor numbers from the protocol. The protocol versions to be
supported in a given build are specified here.
2. The name of the AMQP specification file has changed from amqp.xml to
amqp-<major>.<minor>.xml. This allows several specification versions to
co-exist in the spec directory.
3. Generated frame code is now generated into a directory
framing_<major>_<minor>. For the moment, the namespace (package) is
unchanged, but this will change to match the directory name in the next
phase.
4. A generated ProtocolVersionList interface has been created which
contains all the currently supported major/minor pairs.
5. The ProtocolInitiation class no longer has a default constructor. The
major and minor version must be supplied to the constructor. The default
protocol is now the last of those in the ProtocolVersionList.
6. The actual major and minor protocol version numbers of the current
session are now a part of the AMQMinaProtocolSession class.

These changes should not be disruptive in any way to existing code,
however I recommend a clean build.

Kim

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message