qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John O'Hara" <john.r.oh...@gmail.com>
Subject Can we release an M1 with a dependency on a MINA-Snapshot version???
Date Thu, 16 Nov 2006 17:06:41 GMT
That's what we need -- some mentor time!

We can use any code (a license is a license is a license).
The question is whether the Incubator PMC will allow it to become M1?

Cliff, James, Paul - any opinion?

In a nutshell: we have a "fix" for MINA that Qpid depends on, but has not
yet been adopted by a released MINA version.
We want to "Release early and often" becuase the user base is building and
they'd like some more fixed targets....

Can Qpid still release an M1?

John

On 16/11/06, Steve Vinoski <vinoski@iona.com> wrote:
>
>
> On Nov 16, 2006, at 11:26 AM, John O'Hara wrote:
>
> > On 15/11/06, Steve Vinoski <vinoski@iona.com> wrote:
> >>
> >> Yes, it can be long. But those are the rules by which we must abide
> >> under Apache. As Rajith points out in a separate email, it's not even
> >> clear that M1 as it stands can get out the door given its dependency
> >> on an unreleased version of mina.
> >>
> >> I don't make the rules. I just want to live by them, as I'm sure we
> >> all do, and I know that maven will help greatly in that regard.
> >
> >
> > With Apache licensed software, we can use any checked in code that
> > bears the
> > license.
>
> Chapter and verse, please. We've had a number of people over the past
> few days assert what the "real" rules are, and now you've just added
> another. These assertions have greatly differed. If I were the M1
> release manager, I would want to see an official Apache document that
> clearly states what's possible in this regard.
>
> I am surprised that our mentors haven't chimed in yet.
>
> --steve
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message