qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Greig" <robert.j.gr...@gmail.com>
Subject Trunk build broken
Date Fri, 22 Dec 2006 21:16:43 GMT
Hi,

It appears the trunk build is broken due to the commit for revision 489715.

The first problem was that protocol-version.xml had this in it:

<exec dir="${gentools.home}/src" executable="pwd" />

which does not work on Windows. However that appears only to be
informational (?) so I just commented it out.

After that I get this failure:

generate:
     [echo] XML files to be processed: ../../specs/amqp.0-8.xml ../../specs/clus
ter.0-8.xml
     [java] java.lang.NoClassDefFoundError: org/apache/qpid/gentools/Main
     [java] Exception in thread "main"
     [java] Java Result: 1
[INFO] Executed tasks
[INFO] Registering compile source root C:\redhat\trunkclean\java\common\target\g
enerated-sources\xsl
[INFO] [resources:resources]
[INFO] Using default encoding to copy filtered resources.
[INFO] [compiler:compile]
Compiling 69 source files to C:\redhat\trunkclean\java\common\target\classes
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Compilation failure

C:\redhat\trunkclean\java\common\src\main\java\org\apache\qpid\framing\ProtocolI
nitiation.java:[137,29] cannot find symbol
symbol  : class ProtocolVersionList
location: class org.apache.qpid.framing.ProtocolInitiation
etc. presumably as a result of the failure to generate.

Any ideas? Is this just a windows problem?

RG

Mime
View raw message