qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steven Shaw" <stes...@gmail.com>
Subject Re: bootstrap problem
Date Tue, 05 Dec 2006 13:35:06 GMT
I'm trying to build from a fresh checkout on RHEL3. Because the
default autoconf version is not support (2.57), I've installed the
following:

  autoconf-2.61
  automake-1.9.6
  libtool-1.5.22
  m4-1.4.8

I've locally added the "set -x" to bootstrap to make it clearer where
the problems are coming from. I'm having a similar problem to what I
was getting at home:

---begin---
$ ./bootstrap
+ aclocal -I m4
+ autoheader
+ libtoolize --automake
+ : java
+ : javac
+ export JAVA JAVAC
+ test -d ../gentools
+ test -d ../specs
+ cd gen
+ rm -f gen-src.mk
+ perl -ne '/warning:|^(if|else|endif|include)\b/ or print' Makefile.am
+ make -f - srcdir=. gen-src.mk
+ cd tests
+ rm -f gen.mk
+ perl -ne '/^include / or print' Makefile.am
+++ pwd
++ dirname /home/pyramid/r015530/build/qpid-trunk/cpp/tests
+ make -f - abs_srcdir=/home/pyramid/r015530/build/qpid-trunk/cpp gen.mk
+ automake
lib/broker/Makefile.am:9: Libtool library used but `LIBTOOL' is undefined
lib/broker/Makefile.am:9:
lib/broker/Makefile.am:9: The usual way to define `LIBTOOL' is to add
`AC_PROG_LIBTOOL'
lib/broker/Makefile.am:9: to `configure.ac' and run `aclocal' and
`autoconf' again.
lib/client/Makefile.am:9: Libtool library used but `LIBTOOL' is undefined
lib/client/Makefile.am:9:
lib/client/Makefile.am:9: The usual way to define `LIBTOOL' is to add
`AC_PROG_LIBTOOL'
lib/client/Makefile.am:9: to `configure.ac' and run `aclocal' and
`autoconf' again.
lib/common/Makefile.am:43: Libtool library used but `LIBTOOL' is undefined
lib/common/Makefile.am:43:
lib/common/Makefile.am:43: The usual way to define `LIBTOOL' is to add
`AC_PROG_LIBTOOL'
lib/common/Makefile.am:43: to `configure.ac' and run `aclocal' and
`autoconf' again.
tests/gen.mk:93: Libtool library used but `LIBTOOL' is undefined
tests/gen.mk:93:
tests/gen.mk:93: The usual way to define `LIBTOOL' is to add `AC_PROG_LIBTOOL'
tests/gen.mk:93: to `configure.ac' and run `aclocal' and `autoconf' again.
tests/Makefile.am:78:   `tests/gen.mk' included from here
---end---

Note that this version of automake does include the libtool.am file

   ~/local/automake-1.9.6/share/automake-1.9/am/libtool.am

Any pointers would be appreciated.

Cheers,
Steve.

Mime
View raw message