qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steven Shaw" <stes...@gmail.com>
Subject Re: bootstrap problem
Date Tue, 05 Dec 2006 15:00:50 GMT
On 05/12/06, Alan Conway <aconway@redhat.com> wrote:
> Steve, I did this with the initial patch from 2.60->2.59 can you try it
> with RHEL 3 versions? I changed the AC_PREREQ(2.59) in configure.ac, and
> a couple other things - if you run with the default RHEL 3 tools the
> error messages will tell you what needs changing. If we're lucky it'll
> just work with lower versions. If not, post the errors and we'll try to
> make it work unless there's some showstopper. That would be better than
> requiring a bunch of special versions of the tools to be installed every
> time someone wants to build Qpid.

Oh. I backed the AC_PREREQ to 2.57 and automake requirement to 1.6.3
in Makefile.am. From bootstrap I get:

--begin--
~/build/qpid-trunk/cpp
> ./bootstrap
+ aclocal -I m4
+ autoheader
+ libtoolize --automake
+ : java
+ : javac
+ export JAVA JAVAC
+ test -d ../gentools
+ test -d ../specs
+ cd gen
+ rm -f gen-src.mk
+ perl -ne '/warning:|^(if|else|endif|include)\b/ or print' Makefile.am
+ make -f - srcdir=. gen-src.mk
+ cd tests
+ rm -f gen.mk
+ perl -ne '/^include / or print' Makefile.am
+++ pwd
++ dirname /home/pyramid/r015530/build/qpid-trunk/cpp/tests
+ make -f - abs_srcdir=/home/pyramid/r015530/build/qpid-trunk/cpp gen.mk
+ automake
configure.ac:20: `automake requires `AM_CONFIG_HEADER', not `AC_CONFIG_HEADER'
configure.ac: required file `build-aux/mkinstalldirs' not found
--end--

Thanks for the hand. It's be a few years since I did any serious C/C++
development and I didn't have the pleasure of meeting the autotools -
not from the dev side anyhow.

Cheers,
Steve.

Mime
View raw message