qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Meyering <...@meyering.net>
Subject Re: Automake build system up and running :)
Date Fri, 01 Dec 2006 14:24:38 GMT
[resend]
Alan Conway <aconway@redhat.com> wrote:
> The automake build system is in, building and passing all tests :)
> There is some cleanup left to do and you will get a headache on your
> first commit. Check the README for details.

README says to run ./bootstrap.
You might want to have a separate README-hacking or README-dev for people
working from checked-out sources.  Then README will be relevant to a
wider audience.  Eventually, there will be a distributed source tarball
that will already include all of the pieces generated by ./bootstrap.
Wouldn't want to confuse poor users, making them think they need all of
these esoteric tools just to compile from the tarball.

Also, that build-requirements list is mostly for developers.
There would be a much reduced set for non-developers starting
from a tarball.

Here's a small patch for the bootstrap script,
  - stop if any command fails
  - don't run ./configure

Index: bootstrap
===================================================================
--- bootstrap	(revision 481184)
+++ bootstrap	(working copy)
@@ -1,8 +1,7 @@
 #!/bin/sh
+set -e
 aclocal -I m4
 autoheader
 libtoolize --automake
 automake
 autoconf
-./configure --enable-warnings --prefix=/tmp/qpid-inst CXXFLAGS=-g
-

Mime
View raw message