qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Meyering <...@meyering.net>
Subject Re: bootstrap problem
Date Tue, 05 Dec 2006 18:50:45 GMT
"Steven Shaw" <steshaw@gmail.com> wrote:
> On 05/12/06, Jim Meyering <jim@meyering.net> wrote:
>> Thanks.  I did see it.  ISTR that one problem is you switched
>> from an AC_ macro to a now-deprecated AM_ one.  Support for deprecated
>> bits will likely be phased out in upcoming releases.  So it's best not to
>> use them in new projects.
>
> Yes I did do that. That's what the error message told me to do. Alan
> had suggested that I try getting it working with standard tools on
> RHEL3.

I've tried to explain that there is no point in trying to make
the bootstrap procedure work for older build environments.
In fact, doing so would be seriously counterproductive.

>> Remember that people using such packages are typically encouraged
>> to start with an RPM or a tarball.  That you're using development
>> tools implies you are more, um... adventurous, progressive, etc.,
>> at least on the build-tools front.
>
> Yeah I remember
>
>> That's why I suggested you get the latest stable version of automake.
>
> Well I could do that but it seems to be working already. Are you sure
> automake 1.10 is the latest stable?

Yes.

> As I said, the GNU Automake site doesn't say so I was left to pick my
> own version...

Where did you look?  There may well be a page that needs to be updated.

This is the home page:
  http://sources.redhat.com/automake/
It says:
  The latest released version of Automake is 1.10 and it can be found
  on ftp.gnu.org and its mirrors.

Here's the link:
  ftp://ftp.gnu.org/gnu/automake/automake-1.10.tar.bz2

FYI, the http://www.gnu.org/software/automake/ page does say
"See the GNU Automake home page", which is a link to the above URL.

>> > It seems that libapr-1 isn't included as a link parameter for the tests.
>> >
>> > I've tried greping through the Makefiles and whatnot but can only find
>> > something about setting up the APR CXX flags... no the libs...
>>
>> It's in client/Makefile.am:  Look for APR_LIBS.
>
> APR_LIBS does seem to be used in lib/common/Makefile.am
> It's not there in lib/client/Makefile.am

But nothing in lib/client should need libapr.
libapr should be been linked into the `common' shared library.

> In addition, APR_LIBS doesn't appear to be defined anywhere.

It is defined by configure.
The actual value it gets set to can be seen in lib/common/Makefile.
For me it's empty because I turned it off:

    $ grep APR_LIBS.= lib/common/Makefile
    APR_LIBS =

Mime
View raw message