qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rupert Smith" <rupertlssm...@googlemail.com>
Subject Re: [java]: java.io.IOException: path/to/java1.4: not found
Date Wed, 07 Mar 2007 10:29:17 GMT
I've commented the client-java14 module out of the top level pom, so
its not in the build by default anymore. It is doing something very
wacky to maven. Will add back in once it is in a cleaner state.

Rupert

On 3/7/07, Rupert Smith <rupertlssmith@googlemail.com> wrote:
> Something wrong there with the client-1.4 pom. My intention was to
> make it avoid running any tests by default, unless you set up a path
> to java 1.4 in you local settings.xml. The reason being, that I can't
> make any assumptions about whether or not a java 1.4 jdk is installed
> or where it might be located. Will correct this.
>
> Rupert
>
> On 3/7/07, Gordon Sim <gsim@redhat.com> wrote:
> > I get the following error when running 'mvn -Pfastinstall'
> >
> > [INFO] [surefire:test {execution: surefire-it}]
> > [INFO] Surefire report directory:
> > /home/gordon/qpid/trunk/qpid/java/client-java14/target/surefire-reports
> > [INFO]
> > ------------------------------------------------------------------------
> > [ERROR] BUILD ERROR
> > [INFO]
> > ------------------------------------------------------------------------
> > [INFO] Error while executing forked tests.; nested exception is
> > org.codehaus.plexus.util.cli.CommandLineException: Error while executing
> > process.
> >
> > java.io.IOException: path/to/java1.4: not found
> >
> > It seems to be a result of trying to run some tests for the 1.4
> > retrotranslated code? Is this a result of the build system not finding a
> > 1.4 jvm? I have gcj which is 1.4 compliant, but perhaps the test doesn't
> > like that? I'm assuming I'm not supposed to directly modify the pom with
> > a real path...
> >
> > Also, can we avoid running all tests on fastinstall?
> >
>

Mime
View raw message