qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jonathan Anstey <jans...@iona.com>
Subject Re: Error Building Qpid Performance Tests
Date Wed, 04 Apr 2007 13:52:27 GMT
Spot on Dan. The internal proxy doesn't contain the latest junit-toolkit 
stuff. Mainline Qpid builds fine when I disabled all proxies.

Thanks,
Jon

Daniel Kulp wrote:
> Jon,
>
> Are you using the IONA internal mirrors/proxies of all the repositories?   
> If so, you might want to disable the mirrors in your settings.xml 
> temporarily and see if that helps.
>
> Dan
>
>
> On Wednesday 04 April 2007 08:47, Jonathan Anstey wrote:
>   
>> Rupert,
>>
>> I'm using Maven 2.0.5. After clearing out my m2 repo, the build failed
>> looking for uk.co.thebadgerset:junit-toolkit-maven-plugin:pom:0.5.
>> Actually, after looking at the comments above this plugin (in
>> perftests/pom.xml), I think it should be commented out altogether :)
>>
>> Cheers,
>> Jon
>>
>> Rupert Smith wrote:
>>     
>>> What version of Maven are you using? I changed the depdency version
>>> of junit-toolkit to [1.2.8,) so as not support versions 1.2.8 or
>>> later and not
>>> force dependees onto 1.2.8.
>>>
>>> I'm on maven 2.0.4 which supports this syntax. Are you on an older
>>> or newer
>>> version of Maven than this?
>>>
>>> Maybe you could try deleting your local repository (from
>>> uk.co.thebadgersetdownwards and log4j downwards too) and see if that
>>> might help.
>>>
>>> Rupert
>>>
>>> On 04/04/07, Jonathan Anstey <janstey@iona.com> wrote:
>>>       
>>>> Hi guys,
>>>>
>>>> Is anyone else having trouble building the performance tests? I
>>>> copied the error I'm getting below. BTW changing junit-toolkit back
>>>> to version 0.5 allows the build to proceed.
>>>>
>>>> Thanks,
>>>> Jon
>>>>
>>>>
>>>> [janstey@troy perftests]$ mvn
>>>> [INFO] Scanning for projects...
>>>> [INFO]
>>>>
>>>> -------------------------------------------------------------------
>>>> ---------
>>>>
>>>> [INFO] Building Qpid Performance Tests
>>>> [INFO]    task-segment: [install]
>>>> [INFO]
>>>>
>>>> -------------------------------------------------------------------
>>>> ---------
>>>>
>>>> [INFO] [resources:resources]
>>>> [INFO] Using default encoding to copy filtered resources.
>>>> [INFO]
>>>> -------------------------------------------------------------------
>>>> ----- [ERROR] BUILD ERROR
>>>> [INFO]
>>>> -------------------------------------------------------------------
>>>> ----- [INFO] Failed to resolve artifact.
>>>>
>>>> No versions are present in the repository for the artifact with a
>>>> range [1.2.8,)
>>>>   log4j:log4j:jar:null
>>>>
>>>> from the specified remote repositories:
>>>>   central (http://repo1.maven.org/maven2),
>>>>   junit-toolkit.snapshots
>>>> (http://junit-toolkit.svn.sourceforge.net/svnroot/junit-toolkit/sna
>>>> pshots/
>>>>
>>>> )
>>>>         
>
>   


Mime
View raw message