qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rob Godfrey (JIRA)" <qpid-...@incubator.apache.org>
Subject [jira] Resolved: (QPID-463) Java client doesn't close connection gracefully when faced with broker with unsuported protocol version
Date Wed, 12 Dec 2007 13:08:43 GMT

     [ https://issues.apache.org/jira/browse/QPID-463?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Rob Godfrey resolved QPID-463.
------------------------------

       Resolution: Fixed
    Fix Version/s:     (was: M3)
                   M2.1

> Java client doesn't close connection gracefully when faced with broker with unsuported
protocol version
> -------------------------------------------------------------------------------------------------------
>
>                 Key: QPID-463
>                 URL: https://issues.apache.org/jira/browse/QPID-463
>             Project: Qpid
>          Issue Type: Bug
>          Components: Java Client
>    Affects Versions: M2
>            Reporter: Tomas Restrepo
>            Priority: Minor
>             Fix For: M2.1
>
>
> The java client currently doesn't gracefully handle the case when it finds the broker
uses an unsupported protocol version, when trying to open a new connection. 
> What currently happens is that the Java client never responds with a connection.start-ok
(suggesting it believes it doesn't support the specified protocol version), but neither does
it actually close the TCP connection to the broker. Instead, the client retries the connection
after a while, fails again to respond or close the connection, and eventually fails the connection
after the connection timeout expires. 
> No error is raised to the application opening the connection at any point indicating
the cause of the connection failure is a protocol mismatch.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message