qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arnaud Simon (JIRA)" <qpid-...@incubator.apache.org>
Subject [jira] Closed: (QPID-705) maven can only run tests against an invm 0.8 broker
Date Fri, 18 Jan 2008 13:38:33 GMT

     [ https://issues.apache.org/jira/browse/QPID-705?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Arnaud Simon closed QPID-705.
-----------------------------

    Resolution: Fixed

Examples are using the bse class QpidTestcase that allows connecting to an external broker

> maven can only run tests against an invm 0.8 broker 
> ----------------------------------------------------
>
>                 Key: QPID-705
>                 URL: https://issues.apache.org/jira/browse/QPID-705
>             Project: Qpid
>          Issue Type: Improvement
>          Components: Java Broker, Java Client
>    Affects Versions: M3
>            Reporter: Arnaud Simon
>             Fix For: M3
>
>
> It is currently not possible to run the test against an external server from maven as
we cannot set the context. 
> A solution would be to provide a default JNDI properties file defining an 0.8 and an
0.10 connection factory that are looked up according to the protocol version. The jndi provider
url as to be set from the maven pom and point on that properties file.  
> To be done:
> 1) add a jndi properties file
> 2) change QpidTestCase for looking up connection factories based on  broker version property
(08 or 010) 
> 3) update top level and test pom files to define required test configuration properties


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message