qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arnaud Simon (JIRA)" <qpid-...@incubator.apache.org>
Subject [jira] Created: (QPID-829) Protocol version must be selected based on broker supported version
Date Tue, 04 Mar 2008 10:58:40 GMT
Protocol version must be selected based on broker supported version 
--------------------------------------------------------------------

                 Key: QPID-829
                 URL: https://issues.apache.org/jira/browse/QPID-829
             Project: Qpid
          Issue Type: Improvement
          Components: Java Client
    Affects Versions: M3
            Reporter: Arnaud Simon
             Fix For: M3


Currently 0.10 and 0.8 URLs are different this implies 0.8 users to change their provider
URLs for migrating to 0.10. Ideally the URL format should not change. This means that 0.8
and 0.10 code path would not be selected based on the provider URL but rather negotiated with
the broker. The idea would be to assume that the broker support the major current version
and to potentially downgrade to the broker supported one. 



-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message