qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Danushka Menikkumbura <danus...@wso2.com>
Subject Re: Building Boost for Qpid/C++
Date Mon, 28 Apr 2008 14:38:01 GMT
Alan Conway wrote:
> Danushka Menikkumbura wrote:
>> Hi all,
>>    I found this issue when I was trying to build Boost from the 
>> source distribution.
>>    According to Qpid/C++ documentation (refer to INSTALL file) the 
>> following command is supposed to build Boost libraries.
>>      /bjam -sTOOLS=gcc --prefix=~/qpid-tools
>>
>>    /The generated libraries with this command have the name format 
>> <prefix><library name>-<tooset name>-<threading tag>-<ABI

>> tag><version tag><extension>.
>> .
>>    E.g. libboost_program_options-gcc41-mt-1_34_1.so
>>
>>    In Qpid build system, the Boost libs that are linked have the name 
>> format <prefix><library name><extension>.
>>
>>    The remedy for this issue is twofold.
>>    1. Use the following command instead of what is given in the 
>> INSTALL file.
>>
>>    /bjam -sTOOLS=gcc --layout=system --build-type=complete 
>> --prefix=~/qpid-tools
>>
>>    /This generates all possible variants of libs and hence what we 
>> want, takes longer time to build the libs though.
>>
>>    2. Make use of package management tools to install Boost libs.
>>
>>    On Ubuntu, use the following command.
>>
>>    /sudo apt-get install libboost*-dev
>>
>> /Danushka
>>
>
> Can you submit a patch for the INSTALL file?
Will do.

Danushka
>
> Thanks,
> Alan.
>
>



Mime
View raw message