qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Senaka Fernando" <senaka...@gmail.com>
Subject Re: No generated source inside "gen" directory
Date Sat, 26 Apr 2008 13:25:57 GMT
Hi all,

I ran to the same issue today. What I did was,

1. remove the cpp directory
2. obtain a new checkout of the cpp directory (I got revision 651531)
3. ./bootstrap; ./configure; make

This will lead to the build failure pointed out by Danushka

Regards,
Senaka

On Sat, Apr 26, 2008 at 1:47 AM, Alan Conway <aconway@redhat.com> wrote:

> Andrew Stitcher wrote:
>
>> On Fri, 2008-04-25 at 10:19 -0400, Alan Conway wrote:
>>
>>> Danushka Menikkumbura wrote:
>>>
>>>> Hi all,
>>>>   I get a build error when I try to compile a repository working copy.
>>>> The build fails when it is trying to compile
>>>> generate_MaxMethodBodySize_h.cpp which is supposed to reside inside the gen
>>>> directory. I can not find any generated code inside gen directory. I ran
the
>>>> generate.sh manually but had no luck. Am I doing something wrong here or
>>>> what?. I went through the docs, but could not find any hint.
>>>>
>>>> Danushka
>>>>
>>>>  I'm guessing this is a VPATH build? Andrew Stitcher discovered
>>> yesterday that VPATH builds are broken in the way you describe. You can do
>>> an in-tree build until this get fixed, or if you're an automake whiz it
>>> would be most helpful if you could take a look yourself. I was a bit of an
>>> automake-dummy when we started getting this build system together and the
>>> code generation parts in particular still suck a little.
>>>
>>
>> Actually I have the VPATH build working ok for many purposes. What is
>> broken AFAICT in VPATH build:
>>
>> make checkbuild
>> make rpmbuild
>>
>> Incidentally make rpmbuild is actually wrong in the in tree build as
>> well in that it doesn't run the system tests (the python/federation
>> test) as it can't find the python directory.
>>
>> Danushka - I'd guess that you need to start with a sufficiently clean
>> tree (for some value of sufficiently)
>>
>>
> Danushka - let us know if you dont get the build working (and let us know
> what the problem was if you do.) I don't want people to be put of
> contributing by such basic stumbling blocks.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message