qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alan Conway <acon...@redhat.com>
Subject [c++] rename size() to encodedSize() for encodable types.
Date Tue, 07 Oct 2008 14:01:45 GMT
As a step towards using standard STL collection interfaces for things
like framing::FieldTable and Array, and towards greater clarity in
general, I'd like to rename size() for encoded types as encodedSize().
size() is used in STL to mean the size of a container. Since some of our
encoded types are also containers (FieldTable, Array), our non-standard
use of size() and count() is confusing.

I've got it done in a working copy. Anyone have objections? 

Diff attached.

View raw message