qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alan Conway <acon...@redhat.com>
Subject Re: [c++] rename size() to encodedSize() for encodable types.
Date Tue, 07 Oct 2008 16:45:38 GMT
On Tue, 2008-10-07 at 12:29 -0400, Andrew Stitcher wrote:
> On Tue, 2008-10-07 at 10:01 -0400, Alan Conway wrote:
> > As a step towards using standard STL collection interfaces for things
> > like framing::FieldTable and Array, and towards greater clarity in
> > general, I'd like to rename size() for encoded types as encodedSize().
> > size() is used in STL to mean the size of a container. Since some of our
> > encoded types are also containers (FieldTable, Array), our non-standard
> > use of size() and count() is confusing.
> > 
> > I've got it done in a working copy. Anyone have objections? 
> 
> I think that sounds like a good idea.
> 
> > 
> > Diff attached.
> 
> You haven't compiled this diff, have you? :)

I have, and it passed make check. Maybe there's been a commit since.


Mime
View raw message