qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrea Gazzarini <a.gazzar...@gmail.com>
Subject Re: WsDmAdapterTest Failure
Date Mon, 09 Feb 2009 17:29:29 GMT
Thanks Martin but I think that there should be something else on your
TEST-org.apache.qpid.management.wsdm.WsDmAdapter.xml (this is the name
of the result file on my machine I don't know if is the same on your
env)
If so could you send me that?

Regards
Andrea

On 2/9/09, Martin Ritchie <ritchiem@apache.org> wrote:
> 2009/2/9 Andrea Gazzarini <a.gazzarini@gmail.com>:
>> Hi all,could you (when you have time) be so kindly to run the QMan test
>> suite in order to see if there's any failure?In this case please send me
>> the
>> test result...
>>
>> Thanks
>> Andrea
>>
>> 2009/2/9 Andrea Gazzarini <a.gazzarini@gmail.com>
>>
>>> Martin,Rafael, any news on your side?
>>> This morning  Arnaud ran successfully the test on his environment (Fedora
>>> 10); on my side I ran successfully the WsDmAdapterTest on windows and on
>>> people.apache.org (If I remember it should be FreeBSD) and it's working.
>>>
>>> Let me know
>>>
>>> Regards,
>>> Andrea
>>>
>>> 2009/2/7 Andrea Gazzarini <a.gazzarini@gmail.com>
>>>
>>> @Martin & Raphael : could you send me the result (xml or txt) of the
>>>> WsDmAdapter?
>>>> As I see Martin problem is due to some network configuration issue
>>>> (Tests
>>>> are starting Jetty on localhost:8080...I don't know your environment so
>>>> if
>>>> you think it is a problem let me know)
>>>>
>>>> Concerning Raphael issue, that's something that has to do with
>>>> xalan...are
>>>> you sure your environment doesn't include some other  xalan
>>>> implementation?
>>>>
>>>> Anyway please send me the test result and I will understand better
>>>> what's
>>>> happening.
>>>>
>>>> Regards,
>>>> Andrea
>>>>
>>>> 2009/2/7 Robbie Gemmell <gemmellr@dcs.gla.ac.uk>
>>>>
>>>> Im not sure about your issue, but I think Andrea could be right about
>>>>> Martins problem. The webserver started by the tests looks to be on port
>>>>> 8080
>>>>> from some output I saw, so it could be clashing with something else.
>>>>> I'll
>>>>> continue to be the odd one out either way, as they seem work fine for
>>>>> me
>>>>> (Ubuntu 8.04, JDK 1.6.0_06 ...I can fire up RHEL 4.X and 5.X if other
>>>>> opinions are needed though).
>>>>>
>>>>>    [junit] Running org.apache.qpid.management.wsdm.WsDmAdapterTest
>>>>>    [junit] Tests run: 12, Failures: 0, Errors: 0, Time elapsed: 6.398
>>>>> sec
>>>>>
>>>>> Testcase: testGeResourcePropertiesOK took 1.452 sec
>>>>> Testcase: testSetResourcePropertiesOK took 0.324 sec
>>>>> Testcase: testSetResourcePropertiesKO took 0.23 sec
>>>>> Testcase: testGetMultipleResourcePropertiesOK took 0.289 sec
>>>>> Testcase: testOperationInvocationOK_withSimpleTypes took 0.238 sec
>>>>> Testcase: testOperationInvocationOK_withWrapperArrays took 0.216 sec
>>>>> Testcase: testOperationInvocationOK_withPrimitiveArrays took 0.221 sec
>>>>> Testcase: testOperationInvocationOK_withByteArray took 0.214 sec
>>>>> Testcase: testSimpleOperationInvocationOK took 0.288 sec
>>>>> Testcase: testInvocationException_OK took 0.211 sec
>>>>> Testcase: testOperationInvocationOK_withUUID took 0.218 sec
>>>>> Testcase: testOperationInvocationOK_withMap took 0.221 sec
>>>>>
>>>>> Etc etc
>>>>>
>>>>> -----Original Message-----
>>>>> From: Rafael Schloming [mailto:rafaels@redhat.com]
>>>>> Sent: 06 February 2009 23:42
>>>>> To: dev@qpid.apache.org
>>>>> Subject: Re: WsDmAdapterTest Failure[MESSAGE NOT SCANNED]
>>>>>
>>>>> Martin Ritchie wrote:
>>>>> > Hi all, been meaning to say for a while now. All the tests in
>>>>> > WsDmAdapterTest fail like this for me:
>>>>> >
>>>>> > I'm running JDK 1.6.0_10 on a RHEL 4 box. Anyone any thoughts?
>>>>> >
>>>>> > Testcase: testGeResourcePropertiesOK took 0.14 sec
>>>>> >         Caused an ERROR
>>>>> > Connection refused
>>>>> > org.apache.muse.ws.addressing.soap.SoapFault: Connection refused
>>>>> >         at
>>>>> org.apache.muse.core.AbstractResourceClient.invoke(AbstractResourceClient.java:298)
>>>>> >         at
>>>>> org.apache.muse.core.AbstractResourceClient.invoke(AbstractResourceClient.java:254)
>>>>> >         at
>>>>> org.apache.muse.ws.resource.remote.WsResourceClient.getResourceProperty(WsResourceClient.java:138)
>>>>> >         at
>>>>> org.apache.muse.ws.resource.sg.remote.ServiceGroupClient.getMembers(ServiceGroupClient.java:110)
>>>>> >         at
>>>>> org.apache.qpid.management.wsdm.WsDmAdapterTest.setUp(WsDmAdapterTest.java:160)
>>>>> >         at
>>>>> junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
>>>>> >         at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
>>>>> >         at junit.extensions.TestSetup.run(TestSetup.java:23)
>>>>>
>>>>> They all fail for me as well. I get this exception logged:
>>>>>
>>>>> 15:47:32,774 ERROR [WsdlBuilder] <QMAN-100026> : Exception occurred
>>>>> while replacing the placeholder soap address with r\
>>>>> esource actual location.
>>>>> java.lang.ClassCastException: org.apache.xml.dtm.ref.DTMManagerDefault
>>>>> cannot be cast to org.apache.xml.dtm.DTMManager
>>>>>         at
>>>>> org.apache.xml.dtm.DTMManager.newInstance(DTMManager.java:135)
>>>>>         at org.apache.xpath.XPathContext.<init>(XPathContext.java:100)
>>>>>         at org.apache.xpath.XPathAPI.eval(XPathAPI.java:221)
>>>>>         at
>>>>> org.apache.xpath.XPathAPI.selectNodeIterator(XPathAPI.java:126)
>>>>>         at org.apache.xpath.XPathAPI.selectSingleNode(XPathAPI.java:87)
>>>>>         at org.apache.xpath.XPathAPI.selectSingleNode(XPathAPI.java:67)
>>>>>         at
>>>>>
>>>>> org.apache.qpid.management.wsdm.capabilities.WsdlBuilder.begin(WsdlBuilder.java:209)
>>>>>
>>>>> ...
>>>>>
>>>>> And the tests fail like this:
>>>>>
>>>>> Testcase: testOperationInvocationOK_withMap took 0.178 sec
>>>>>         FAILED
>>>>> One resource has just been created so I expect to find it on service
>>>>> group children list... expected:<1> but was:<0>
>>>>> junit.framework.AssertionFailedError: One resource has just been
>>>>> created
>>>>> so I expect to find it on service group childr\
>>>>> en list... expected:<1> but was:<0>
>>>>>         at
>>>>>
>>>>> org.apache.qpid.management.wsdm.WsDmAdapterTest.setUp(WsDmAdapterTest.java:174)
>>>>>         at
>>>>> junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
>>>>>         at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
>>>>>         at junit.extensions.TestSetup.run(TestSetup.java:25)
>>>>>
>>>>> --Rafael
>>>>>
>>>>> ---------------------------------------------------------------------
>>>>> Apache Qpid - AMQP Messaging Implementation
>>>>> Project:      http://qpid.apache.org
>>>>> Use/Interact: mailto:dev-subscribe@qpid.apache.org
>>>>>
>>>>>
>>>>>
>>>>> ---------------------------------------------------------------------
>>>>> Apache Qpid - AMQP Messaging Implementation
>>>>> Project:      http://qpid.apache.org
>>>>> Use/Interact: mailto:dev-subscribe@qpid.apache.org
>>>>>
>
> Hi, it has been much better today however if the test is starting a
> server process it may not be waiting for it to be completely shutdown.
> I had two test runs that succeeded. However on my main dev branch it
> failed again just now.
>
> Error	Connection refused
> org.apache.muse.ws.addressing.soap.SoapFault: Connection refused
> at
> org.apache.muse.core.AbstractResourceClient.invoke(AbstractResourceClient.java:298)
> at
> org.apache.muse.core.AbstractResourceClient.invoke(AbstractResourceClient.java:254)
> at
> org.apache.muse.ws.resource.remote.WsResourceClient.getResourceProperty(WsResourceClient.java:138)
> at
> org.apache.muse.ws.resource.sg.remote.ServiceGroupClient.getMembers(ServiceGroupClient.java:110)
> at
> org.apache.qpid.management.wsdm.WsDmAdapterTest.setUp(WsDmAdapterTest.java:160)
> at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
> at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
> at junit.extensions.TestSetup.run(TestSetup.java:23)
>
> That is all I get in the log files.
>
> Sorry I don't have any more details.
>
> Running on RHEL4, JDK 1.6.0_10
>
> --
> Martin Ritchie
>
> ---------------------------------------------------------------------
> Apache Qpid - AMQP Messaging Implementation
> Project:      http://qpid.apache.org
> Use/Interact: mailto:dev-subscribe@qpid.apache.org
>
>

-- 
Sent from my mobile device

---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:dev-subscribe@qpid.apache.org


Mime
View raw message