qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrea Gazzarini <a.gazzar...@gmail.com>
Subject Re: Help for building java trunk
Date Mon, 16 Mar 2009 10:23:57 GMT
+1 on this :)
Andrea

2009/3/16 Martin Ritchie <ritchiem@apache.org>

> 2009/3/13 Andrea Gazzarini <a.gazzarini@gmail.com>:
> > I had the same problem some month ago...below you can find the
> corresponding
> > thread, hope it helps.Briefly: 1.5 compiler doesn't allow the usage of
> > @Override for implementors methods, just only for effective override.
> > This is supported (implementors) only from jdk 1.6
> >
> > Regards,
> > Andrea
>
> As we say we support 1.5 we should ensure that these @Override
> instances are removed.
>
> Regards
> Martin
> > 2009/1/15 Robbie Gemmell <gemmellr@dcs.gla.ac.uk>
> >
> >> Perhaps you had already built it once at the top level when you ran the
> >> sub-module's build, and it works after the second compile.
> >>
> >> You were right as to why it happens though, and its a known issue. I
> >> believe all such occurrences were removed not that long ago in order to
> >> prevent this happening, but i recall seeing some traffic about threading
> >> even more recently, so this is probably just a new occurrence of it
> >> since then.
> >>
> >> Most people are using Java 6 compilers and targeting Java5, and it
> >> doesnt show up in that scenario so its quite easy for it to go unseen.
> >>
> >> Robbie
> >>
> >> On Thu, 2009-01-15 at 13:10 +0100, Andrea Gazzarini wrote:
> >> > Thanks Marnie, Thing is strange because the each module compiles
> fine..I
> >> > have this error only when I run ant from the java root...
> >> > Anyway, in order to see if my submitted work builds, I built common
> and
> >> > client modules separately.
> >> >
> >> > I will try your workaround too
> >> >
> >> > Thanks again.
> >> >
> >> > Andrea
> >> >
> >> >
> >> > 2009/1/15 Marnie McCormack <marnie.mccormack@googlemail.com>
> >> >
> >> > > Hi Andrea,
> >> > >
> >> > > There are some JIRAs around for this (the old ones are the best) -
> try
> >> > > running again, I believe it works the second time :-)
> >> > >
> >> > > Marnie
> >> > >
> >> > > On Thu, Jan 15, 2009 at 9:12 AM, Andrea Gazzarini <
> >> a.gazzarini@gmail.com
> >> > > >wrote:
> >> > >
> >> > > > Hi,
> >> > > > Ant issue has been solved! Finally I found ant and I'm able to
run
> >> the
> >> > > > build.
> >> > > >
> >> > > > Now I have a question : the build fails if java 1.5 is used...is
> that
> >> > > > expected?
> >> > > >
> >> > > > Problem seems due to the fact that only from JDK1.6 the @Override
> >> > > > annotation
> >> > > > can be used for annotate an implementor method. JDK 1.5 requires
> that
> >> the
> >> > > > method is really overriden. QpidThreadExecutor.execute(Runnable)
> >> seems to
> >> > > > be
> >> > > > an implementation of the Executor inteface.
> >> > > >
> >> > > >
> >> > > >
> >> > >
> >>
> ================================================================================================
> >> > > > Buildfile: build.xml
> >> > > >     [echo] Running ant for module : client
> >> > > >
> >> > > > prepare:
> >> > > >
> >> > > > precompile:
> >> > > >
> >> > > > compile:
> >> > > >     [echo] Targeting : 1.5
> >> > > >    [javac] Compiling 134 source files to
> >> > > > /x1/home/agazzarini/qpid/trunk/qpid/java/build/client/classes
> >> > > >    [javac]
> >> > > >
> >> > > >
> >> > >
> >>
> /x1/home/agazzarini/qpid/trunk/qpid/java/client/src/main/java/org/apache/qpid/client/transport/QpidThreadExecutor.java:9:
> >> > > > method does not override a method from its superclass
> >> > > >    [javac]     @Override
> >> > > >    [javac]      ^
> >> > > >    [javac] Note: Some input files use or override a deprecated
> API.
> >> > > >    [javac] Note: Recompile with -Xlint:deprecation for details.
> >> > > >    [javac] Note: Some input files use unchecked or unsafe
> operations.
> >> > > >    [javac] Note: Recompile with -Xlint:unchecked for details.
> >> > > >    [javac] 1 error
> >> > > >
> >> > > > BUILD FAILED
> >> > > >
> >> > > >
> >> > >
> >>
> ============================================================================
> >> > > >
> >> > > > Regards,
> >> > > > Andrea
> >> > > >
> >> > > > 2009/1/15 Andrea Gazzarini <a.gazzarini@gmail.com>
> >> > > >
> >> > > > > Hi all,I just submitted QMan WS-DM so I'd need to run a
manual
> >> build in
> >> > > > > order to see that all is working...
> >> > > > > I tried that on my machine and it builds ok but I'd like
to run
> it
> >> on
> >> > > the
> >> > > > > apache machine too.
> >> > > > > Is ant installed on that machine? If so How can I use it?
> >> > > > >
> >> > > > > Regards,
> >> > > > > Andrea
> >> > > > >
> >> > > >
> >> > >
> >>
> >
>
>
>
>
> --
> Martin Ritchie
>
> ---------------------------------------------------------------------
> Apache Qpid - AMQP Messaging Implementation
> Project:      http://qpid.apache.org
> Use/Interact: mailto:dev-subscribe@qpid.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message