qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aidan Skinner <aidan.skin...@gmail.com>
Subject Re: Build Failure at Revision 753390
Date Sat, 14 Mar 2009 13:31:44 GMT
On Sat, Mar 14, 2009 at 10:18 AM, Thilina Buddhika <thilinamb@gmail.com> wrote:

> Then I imported the broker module to the eclipse via the Ant build file and
> attached the jars of the lib folder manually. Now there are some errors in
> the org.apache.qpid.server.protocol.AMQPFastProtocolHandler class. It says
> that it is hard to resolve the following classes.

You need to build it with ant first so that the code generator runs
and then add build/<project>/src to your source path for common,
client and broker.

> I am not sure whether I am doing the correct thing. How can I import this
> into an IDE successfully ?

It's a bit more long-winded than it was when we had maven, but here's
what I do in eclipse after i've done ant build:

new project from existing filesystem
add the generated source
add every library in lib/
fix the project deps - broker and client depend on common etc. Eclipse
normally guesses these right for me.

I may be missing a step, I haven't done this in a while but I think
that's everything.

I'm hoping having meaningful poms will make this a bit simpler in the future.

- Aidan
-- 
Apache Qpid - World Domination through Advanced Message Queueing
http://qpid.apache.org

---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:dev-subscribe@qpid.apache.org


Mime
View raw message