qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alan Conway (JIRA)" <qpid-...@incubator.apache.org>
Subject [jira] Commented: (QPID-2202) CMake doesn't check for presence of boost-system
Date Thu, 10 Dec 2009 18:44:18 GMT

    [ https://issues.apache.org/jira/browse/QPID-2202?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12788830#action_12788830
] 

Alan Conway commented on QPID-2202:
-----------------------------------

 r889358 adds the boost_system library to the set thats tested for. It has been tested on
 an older boost without the system lib:

boost-1.33.1-10.el5
cmake-2.4.8-3.el5

and on a newer one with it

boost-1.37.0-7.fc11.x86_64
cmake-2.6.4-3.fc11.x86_64

It works for both those combinations. Not sure if resolves the windows issue mentioned here.

> CMake doesn't check for presence of boost-system
> ------------------------------------------------
>
>                 Key: QPID-2202
>                 URL: https://issues.apache.org/jira/browse/QPID-2202
>             Project: Qpid
>          Issue Type: Bug
>          Components: Build Tools
>         Environment: Windows XP, CMake 2.6 patch 4, Boost 1.37 from BoostPro, qpid trunk
r834975
>            Reporter: Jeff Laughlin
>
> CMake doesn't check for presence of boost-system library. It successfully configures
and generates, but building in VC9 fails on linking when it cannot find the library. Installing
the library and re-linking works around the issue.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:dev-subscribe@qpid.apache.org


Mime
View raw message