qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robbie Gemmell" <robbie.gemm...@gmail.com>
Subject RE: Could not connect to the java broker
Date Fri, 01 Jan 2010 11:44:57 GMT
Hi Harsha,

I have just tried and was able to start the (trunk) broker by running the
create-example-ssl-stores.sh script in the bin/ directory to create
bin/qpid.keystore and bin/qpid.truststore and then just copying your
keystore configuration below. I will verify the bat script later, but that
worked the last time I used it too so I'm not sure why you would be having
difficulty with the below config.

However, the reason for your issue appears to be your host definition when
running the console. The hostname you need to enter in the console is the
ip/hostname the broker is running on, not a VirtualHost name from the broker
configuration. So if you are running both server and console locally you
would enter e.g localhost or 127.0.0.1

I would recommend you could try the JMX Management Console from trunk if you
aren't already, it has a significantly nicer UI now than it did with 0.5 and
I have recently made some modifications to it to make it more obvious what
went wrong if it fails to connect. 

You can build the console by running "ant build release-bin" (no quotes) in
the qpid/java subdirectory of the trunk. The full console application
releases are then prepared in qpid/java/management/eclipse-plugin/release
(pick the one that matches your platform).

Robbie


> -----Original Message-----
> From: Harsha Halgaswatta [mailto:harsha.halgaswatta@gmail.com]
> Sent: 01 January 2010 05:27
> To: dev@qpid.apache.org
> Subject: Could not connect to the java broker
> 
> First Wishing you all a very happy new year ....
> 
> I tried connecting *java* broker using eclipse Qpid Management console
> plug
> in. But i could not , What i have done is as follows
> 
> 
>    - Note : I used a fresh checkout from the trunk.
>    - Tried both ways enabling and disabling SSL authentication
> 
> 
>    - When using SSL authentication i used both example keystore created
> from
>    sample script and existing test keystore.
> 
> 
>    - I was able to start it with
>    <keyStorePath>${prefix}/../test-
> profiles/test_resources/ssl/keystore.jks</keyStorePath>
> 
> 
> 
>    -  but not with  *
> *<keyStorePath>${QPID_HOME}/bin/qpid.keystore</keyStorePath>
>    , did not change any password. used excisting ones.\\
> 
> 
>    - with *<keyStorePath>${QPID_HOME}/bin/qpid.keystore</keyStorePath>*
> it
>    says JMX management SSL keystore path not defined, unable to start
> SSL
>    protected JMX ConnectorServer
> 
> 
> When i am connecting to the started broker with eclipse QM console it
> says *Unable
> to connect to the specified JMX server.
> *
>  i used   hostname : test (specified as default in virtualhosts)
>               port          : 8999
>               usename  : guest    ; also tried with admin as well
>               password : guest*   ; *also tried with admin as well
> 
> Appreciate if you can give me any advice on this, perhaps i may have
> missed
> something
> 
> Thanks in advance.
> Harsha
> *
>  *


---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:dev-subscribe@qpid.apache.org


Mime
View raw message