qpid-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kerry Bonin <kerrybo...@gmail.com>
Subject Status of Windows SSL / ACL ?
Date Wed, 03 Feb 2010 20:42:39 GMT
Hello!  I had a few questions regarding the state of broker security for
Windows platforms.

On the SSL front, I see QPID-1403 has been resolved, and I can now build w/
BUILD_SSL enabled.  What I haven't been able to get working yet is to get my
broker to actually load a certificate - ::CertFindCertificateInStore fails.
On this issue, do we have a known good set of instructions to generate a
working system?  The windows error ("Cannot find object or property") is so
vague I'm not sure why it isn't loading my cert.  I'm generating a
self-signed cert w/ openssl, loading as trusted root cert, generating a
client cert w/ the CN of my node, converting to pkcs12 along w/ password
free private key and importing to the personal store w/ friendly name of
node, not sure what else I need to do...

On the ACL front, QPID-1842 is still keeping Windows link from working.  Any
idea when this will be fixed?

On a related note, I have time to help fix these, as I need secure broker
(with clustering) on the Windows platform working in the next few months for
my project here.

Appreciate any pointers, and please let me know if there is anything I can
do to help...

Kerry Bonin
Sr. Systems Architect
GE Security

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message